Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.debian.kernel > #82304 > unrolled thread
| Started by | Richard Rosner <richard@rosner-online.de> |
|---|---|
| First post | 2024-04-24 16:20 +0200 |
| Last post | 2024-04-24 16:20 +0200 |
| Articles | 1 — 1 participant |
Back to article view | Back to linux.debian.kernel
Bug#1069777: initramfs-tools: Bug/feature request: better handling of /etc/crypttab not ending in new line character Richard Rosner <richard@rosner-online.de> - 2024-04-24 16:20 +0200
| From | Richard Rosner <richard@rosner-online.de> |
|---|---|
| Date | 2024-04-24 16:20 +0200 |
| Subject | Bug#1069777: initramfs-tools: Bug/feature request: better handling of /etc/crypttab not ending in new line character |
| Message-ID | <IwLDz-8DPX-7@gated-at.bofh.it> |
[Multipart message — attachments visible in raw view] — view raw
Package: initramfs-tools Version: 0.142 Severity: wishlist Dear Maintainer, I'm not sure if this is a bug that should be fixed or a feature request for better error handling. I noticed by accident, that when /etc/crypttab ends in the line of the last entry and not a new line character, update-initramfs just ignores the last line and says it couldn't find that device in /etc/crypttab. Either the tool should be able to just handle this rather simple case or at least give a proper error message. Or whatever would make it more obvious for the user what actually the error is as the existing error message is quite misleading. Best Richard
Back to top | Article view | linux.debian.kernel
csiph-web