Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.debian.kernel > #77996 > unrolled thread

Bug#1029336: Regression: unable to mount root fs on unknown-block

Started byJames Addison <jay@jp-hosting.net>
First post2023-01-21 13:50 +0100
Last post2023-01-21 20:40 +0100
Articles 5 — 3 participants

Back to article view | Back to linux.debian.kernel


Contents

  Bug#1029336: Regression: unable to mount root fs on unknown-block James Addison <jay@jp-hosting.net> - 2023-01-21 13:50 +0100
    Bug#1029336: Regression: unable to mount root fs on unknown-block Salvatore Bonaccorso <carnil@debian.org> - 2023-01-21 15:00 +0100
    Bug#1029336: Regression: unable to mount root fs on unknown-block James Addison <jay@jp-hosting.net> - 2023-01-21 19:30 +0100
      Bug#1029336: Regression: unable to mount root fs on unknown-block Salvatore Bonaccorso <carnil@debian.org> - 2023-01-21 20:40 +0100
    Bug#1029336: marked as done (Regression: unable to mount root fs  on unknown-block) "Debian Bug Tracking System" <owner@bugs.debian.org> - 2023-01-21 20:40 +0100

#77996 — Bug#1029336: Regression: unable to mount root fs on unknown-block

FromJames Addison <jay@jp-hosting.net>
Date2023-01-21 13:50 +0100
SubjectBug#1029336: Regression: unable to mount root fs on unknown-block
Message-ID<FQltL-6Nt-1@gated-at.bofh.it>
Package: linux-image-6.1.0-1-rt-amd64
Severity: critical
Justification: breaks the whole system

Dear Maintainer,

When attempting to boot a ThinkPad X230 from kernel build 6.1.0-1-rt-amd64, the
following error occurs (transcribed from screen; apologies in advance for any
typos):

  [...] No filesystem could mount root, tried :
  [...] 
  [...] Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)
  [...] CPU: 0 PID: 1 Comm: swapper/0 Not tainted 6.1.0-1-rt-amd64 #1  Debian 6.1.4-1
  [...] Hardware name: <disk and BIOS details>
  [...] Call Trace:
  [...]  <TASK>
  [...]  dump_stack_lvl+0x44/0x5c
  [...]  panic+0x10e/0x2db
  [...]  mount_block_root+0x1d3/0x1e6
  [...]  prepare_namespace+0x136/0x165
  [...]  kernel_init_freeable+0x25c/0x286
  [...]  ? rest_init+0xd0/0xd0
  [...]  kernel_init+0x16/0x130
  [...]  ret_from_fork+0x22/0x30
  [...]  </TASK>
  [...] Kernel Offset: 0x18600000 from 0xffffffff81000000 (relocation range: 0xffffffff80000000-0xffffffffbfffffff)

This prevents the system from booting.

Adding the 'rootwait' option to the kernel commandline as mentioned in a
similar-sounding upstream bug prevents the panic, but the system pauses,
seemingly forever, without finding the filesystem to mount.

The reason that I believe this is a regression is:

 - The problem does _not_ occur for the non-rt build (6.1.0-1-amd64)
 - The problem does _not_ occur with a recent rt build (6.0.0.6-rt-amd64)

Thank you,
James

[toc] | [next] | [standalone]


#77997

FromSalvatore Bonaccorso <carnil@debian.org>
Date2023-01-21 15:00 +0100
Message-ID<FQmzw-7qx-3@gated-at.bofh.it>
In reply to#77996
Control:tags -1 + moreinfo

On Sat, Jan 21, 2023 at 12:40:07PM +0000, James Addison wrote:
> Package: linux-image-6.1.0-1-rt-amd64
> Severity: critical
> Justification: breaks the whole system
> 
> Dear Maintainer,
> 
> When attempting to boot a ThinkPad X230 from kernel build 6.1.0-1-rt-amd64, the
> following error occurs (transcribed from screen; apologies in advance for any
> typos):
> 
>   [...] No filesystem could mount root, tried :
>   [...] 
>   [...] Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)
>   [...] CPU: 0 PID: 1 Comm: swapper/0 Not tainted 6.1.0-1-rt-amd64 #1  Debian 6.1.4-1
>   [...] Hardware name: <disk and BIOS details>
>   [...] Call Trace:
>   [...]  <TASK>
>   [...]  dump_stack_lvl+0x44/0x5c
>   [...]  panic+0x10e/0x2db
>   [...]  mount_block_root+0x1d3/0x1e6
>   [...]  prepare_namespace+0x136/0x165
>   [...]  kernel_init_freeable+0x25c/0x286
>   [...]  ? rest_init+0xd0/0xd0
>   [...]  kernel_init+0x16/0x130
>   [...]  ret_from_fork+0x22/0x30
>   [...]  </TASK>
>   [...] Kernel Offset: 0x18600000 from 0xffffffff81000000 (relocation range: 0xffffffff80000000-0xffffffffbfffffff)
> 
> This prevents the system from booting.
> 
> Adding the 'rootwait' option to the kernel commandline as mentioned in a
> similar-sounding upstream bug prevents the panic, but the system pauses,
> seemingly forever, without finding the filesystem to mount.
> 
> The reason that I believe this is a regression is:
> 
>  - The problem does _not_ occur for the non-rt build (6.1.0-1-amd64)
>  - The problem does _not_ occur with a recent rt build (6.0.0.6-rt-amd64)

Can you please try with 6.1.7-1 which is present in unstable?

Regards,
Salvatore

[toc] | [prev] | [next] | [standalone]


#78000

FromJames Addison <jay@jp-hosting.net>
Date2023-01-21 19:30 +0100
Message-ID<FQqMN-aba-11@gated-at.bofh.it>
In reply to#77996
Package: src:linux
Followup-For: Bug #1029336

Thanks, Salvatore - I can confirm that the issue is fixed after an install of
version 6.1.7-1 from 'unstable'.

The system _also_ boots fine after installing version 6.1.4-1 from 'testing'.
Perhaps there was a corrupt/misconfigured initrd build on the machine before.

Let me know if more details would be useful; the issue is resolved here.

[toc] | [prev] | [next] | [standalone]


#78001

FromSalvatore Bonaccorso <carnil@debian.org>
Date2023-01-21 20:40 +0100
Message-ID<FQrSx-aOC-7@gated-at.bofh.it>
In reply to#78000
Hi James,

On Sat, Jan 21, 2023 at 06:26:19PM +0000, James Addison wrote:
> Package: src:linux
> Followup-For: Bug #1029336
> 
> Thanks, Salvatore - I can confirm that the issue is fixed after an install of
> version 6.1.7-1 from 'unstable'.
> 
> The system _also_ boots fine after installing version 6.1.4-1 from 'testing'.
> Perhaps there was a corrupt/misconfigured initrd build on the machine before.
> 
> Let me know if more details would be useful; the issue is resolved here.

Thanks for testing and for reporting back the above. Indeed I would
consider then this bug to be closed, doing so now.

If you still have the logs from the previous packages installation
(check /var/log/apt/term.log* for instance), then you can check if
there indeed was a problem on package installation and initrd update.

Regards,
Salvatore

[toc] | [prev] | [next] | [standalone]


#78002 — Bug#1029336: marked as done (Regression: unable to mount root fs on unknown-block)

From"Debian Bug Tracking System" <owner@bugs.debian.org>
Date2023-01-21 20:40 +0100
SubjectBug#1029336: marked as done (Regression: unable to mount root fs on unknown-block)
Message-ID<FQrSy-aOC-21@gated-at.bofh.it>
In reply to#77996

[Multipart message — attachments visible in raw view] — view raw

Your message dated Sat, 21 Jan 2023 20:38:19 +0100
with message-id <Y8w/K+H9xyZbRgIn@eldamar.lan>
and subject line Re: Bug#1029336: Regression: unable to mount root fs on unknown-block
has caused the Debian Bug report #1029336,
regarding Regression: unable to mount root fs on unknown-block
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org
immediately.)


-- 
1029336: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1029336
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems

[toc] | [prev] | [standalone]


Back to top | Article view | linux.debian.kernel


csiph-web