Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.debian.kernel > #86421
| From | Bastian Blank <waldi@debian.org> |
|---|---|
| Newsgroups | linux.debian.bugs.dist, linux.debian.kernel |
| Subject | Bug#1100015: In-kernel X.509 certificates fail to load since 6.13.6 |
| Date | 2025-03-11 17:10 +0100 |
| Message-ID | <Kpal3-5idG-13@gated-at.bofh.it> (permalink) |
| References | <KoJ1v-50aR-13@gated-at.bofh.it> <KoJ1v-50aR-13@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
Cross-posted to 2 groups.
On Mon, Mar 10, 2025 at 12:51:35PM +0200, Raul Tambre wrote:
> Starting with 6.13.6-1~exp1 the following error is logged during boot:
>
> Mar 10 12:11:53 laptop kernel: Loading compiled-in X.509 certificates
> Mar 10 12:11:53 laptop kernel: Problem loading in-kernel X.509 certificate (-2)
>
> I imagine this is likely caused by commit ca3d0e60f548ed18c360fa87c5a2966606862b05 ("Store build time signing key encrypted").
Yeah. And the immediate reason:
| -Signature Algorithm: sha256WithRSAEncryption
| +Signature Algorithm: ecdsa-with-SHA256
The old kernel tried to configure with ecdsa, but failed, due to some
conflicts in the config, falling back to rsa.
And missing support for ecdsa, but for some reason built-in suport for
rsa.
| root@boot1:/usr/lib/debug/boot# grep CONFIG_CRYPTO_RSA /boot/config-6.1*
| /boot/config-6.12.17-cloud-amd64:CONFIG_CRYPTO_RSA=y
| /boot/config-6.13-cloud-amd64:CONFIG_CRYPTO_RSA=y
| root@boot1:/usr/lib/debug/boot# grep CONFIG_CRYPTO_ECDS /boot/config-6.1*
| /boot/config-6.12.17-cloud-amd64:# CONFIG_CRYPTO_ECDSA is not set
| /boot/config-6.13-cloud-amd64:# CONFIG_CRYPTO_ECDSA is not set
Bastian
--
Knowledge, sir, should be free to all!
-- Harry Mudd, "I, Mudd", stardate 4513.3
Back to linux.debian.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
Bug#1100015: In-kernel X.509 certificates fail to load since 6.13.6 Raul Tambre <raul@tambre.ee> - 2025-03-10 12:00 +0100
Processed: In-kernel X.509 certificates fail to load since 6.13.6 "Debian Bug Tracking System" <owner@bugs.debian.org> - 2025-03-10 12:00 +0100
Bug#1100015: In-kernel X.509 certificates fail to load since 6.13.6 Bastian Blank <waldi@debian.org> - 2025-03-11 17:10 +0100
Bug#1100015: In-kernel X.509 certificates fail to load since 6.13.6 Bastian Blank <waldi@debian.org> - 2025-03-11 17:30 +0100
Bug#1100015: marked as done (In-kernel X.509 certificates fail to load since 6.13.6) "Debian Bug Tracking System" <owner@bugs.debian.org> - 2025-03-14 22:10 +0100
csiph-web