Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.debian.kernel > #87828
| From | Bastian Blank <waldi@debian.org> |
|---|---|
| Newsgroups | linux.debian.bugs.dist, linux.debian.kernel |
| Subject | Bug#1107169: cp --preserve=mode from nfs-mounted share works but returns error |
| Date | 2025-06-03 21:20 +0200 |
| Message-ID | <KTFkZ-7Ys9-1@gated-at.bofh.it> (permalink) |
| References | <KTFkZ-7Ys9-3@gated-at.bofh.it> <KTFkZ-7Ys9-3@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
Cross-posted to 2 groups.
Control: tags -1 moreinfo On Mon, Jun 02, 2025 at 05:31:00PM +0000, bls 3427 wrote: > and the NFS client disk are ext4. > > This works correctly and without error on a Debian 12 X64 or arm64 NFS client system. > > NFS server: > * Debian 12 X64 > * File system fstab entry: /dev/disk/by-partuuid/6ce32e00-7481-b244-9924-f616c327c050 /h ext4 defaults,noatime 0 0 > * /etc/exports entry: /h 192.168.92.0/24(rw,no_root_squash,no_subtree_check,insecure) > > NFS client: > * Debian 13 X64 > * fstab entry: mondo:/h /h nfs rw,noatime,x-systemd.automount,x-systemd.idle-timeout=3600 0 0 > > * NFS mount via mount command: mondo:/h on /h type nfs4 (rw,noatime,vers=4.2,rsize=1048576,wsize=1048576,namlen=255,hard,proto=tcp,timeo=600,retrans=2,sec=sys,clientaddr\ > =192.168.92.116,local_lock=none,addr=192.168.92.9,x-systemd.automount,x-systemd.idle-timeout=3600) > > Copying a file from the NFS server share to the NFS client with no switches works correctly. > > Copying with --preserve=mode copies the file correctly but exits with a failure status. > > d13~/test# ls -l l /h/tmp > total 8 > drwxr-xr-x 2 root root 4096 Jun 2 10:15 . > drwxr-xr-x 19 root root 4096 Jun 2 10:15 .. > -rw-r--r-- 1 root root 0 Jun 2 10:15 foobar > d13~/test# rm -f foobar > d13~/test# cp /h/tmp/foobar . > d13~/test# ls -l foobar > -rw-r--r-- 1 root root 0 Jun 2 10:18 foobar > d13~/test# rm -f foobar > d13~/test# cp --preserve=mode /h/tmp/foobar . > cp: preserving permissions for './foobar': Operation not supported This error message means exactly what it tells: it can't copy some permissions, in this case posix acl. Aka the filesystem you are copying to lacks support for some acl parts. Please show the output of "strace cp --preserve=mode /h/tmp/foobar .". Bastian -- "Life and death are seldom logical." "But attaining a desired goal always is." -- McCoy and Spock, "The Galileo Seven", stardate 2821.7
Back to linux.debian.kernel | Previous | Next — Next in thread | Find similar | Unroll thread
Bug#1107169: cp --preserve=mode from nfs-mounted share works but returns error Bastian Blank <waldi@debian.org> - 2025-06-03 21:20 +0200 Processed: Re: Bug#1107169: cp --preserve=mode from nfs-mounted share works but returns error "Debian Bug Tracking System" <owner@bugs.debian.org> - 2025-06-03 21:20 +0200 Processed: Re: Bug#1107169: cp --preserve=mode from nfs-mounted share works but returns error "Debian Bug Tracking System" <owner@bugs.debian.org> - 2025-06-03 21:20 +0200 Bug#1107169: cp --preserve=mode from nfs-mounted share works but returns error Bastian Blank <waldi@debian.org> - 2025-06-03 21:50 +0200
csiph-web