Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.debian.kernel > #87091
| From | Salvatore Bonaccorso <carnil@debian.org> |
|---|---|
| Newsgroups | linux.debian.bugs.dist, linux.debian.kernel |
| Subject | Bug#1104096: nfsdctl: lockd configuration failure reported after updating to nfs-utils-2.8.3 |
| Date | 2025-04-26 22:50 +0200 |
| Message-ID | <KFUDf-gt2l-5@gated-at.bofh.it> (permalink) |
| References | (3 earlier) <KFUDf-gt2l-13@gated-at.bofh.it> <KFt0l-gaNe-1@gated-at.bofh.it> <KFUDf-gt2l-15@gated-at.bofh.it> <KFt0l-gaNe-1@gated-at.bofh.it> <KFUDf-gt2l-15@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
Cross-posted to 2 groups.
Hi So conclusive, as explained by upstream: 1. the nfsdctl error is harmless, and if nfs-utils used with kernel which does not support the netlink control interfaces for knfsd then falls back to start the server with rpc.nfsd and this is indeed the case. 2. the previous starting with nfsdctl autostart was actually a regression now fixed with 2.8.3, since older nfsdctl just ingored the lockd parameters in nfs.conf nd would not have configured it properly so technically a regression from 1:2.6.2-4+deb12u1 in bookworm to the 2.8.2 based version previously, and now fixed in 2.8.3. Closing thus the issue. Regards, Salvatore
Back to linux.debian.kernel | Previous | Next — Next in thread | Find similar | Unroll thread
Bug#1104096: nfsdctl: lockd configuration failure reported after updating to nfs-utils-2.8.3 Salvatore Bonaccorso <carnil@debian.org> - 2025-04-26 22:50 +0200 Bug#1104096: marked as done (nfs-kernel-server: exports file is not parsed or nfsdctl: lockd configuration failure is reported when parsing) "Debian Bug Tracking System" <owner@bugs.debian.org> - 2025-04-26 22:50 +0200
csiph-web