Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.debian.kernel > #86889
| Path | csiph.com!news.samoylyk.net!gothmog.csi.it!bofh.it!news.nic.it!robomod |
|---|---|
| From | Salvatore Bonaccorso <carnil@debian.org> |
| Newsgroups | linux.debian.bugs.dist, linux.debian.kernel |
| Subject | Bug#1103153: linux-image-6.1.0-33-amd64: kernel fails to boot in xen DomU with pci-passthrough |
| Date | Mon, 14 Apr 2025 18:10:01 +0200 |
| Message-ID | <KBuxH-duGs-1@gated-at.bofh.it> (permalink) |
| References | <KBtih-dtJ6-1@gated-at.bofh.it> <KBtih-dtJ6-1@gated-at.bofh.it> |
| X-Mailbox-Line | From debian-bugs-dist-request@lists.debian.org Mon Apr 14 16:03:08 2025 |
| Old-Return-Path | <debbugs@buxtehude.debian.org> |
| X-Spam-Flag | NO |
| X-Spam-Score | -3.999 |
| Reply-To | Salvatore Bonaccorso <carnil@debian.org>, 1103153@bugs.debian.org |
| Resent-To | debian-bugs-dist@lists.debian.org |
| Resent-Cc | Debian Kernel Team <debian-kernel@lists.debian.org> |
| X-Debian-Pr-Message | followup 1103153 |
| X-Debian-Pr-Package | src:linux |
| X-Debian-Pr-Source | linux |
| MIME-Version | 1.0 |
| Content-Type | text/plain; charset=us-ascii |
| Content-Disposition | inline |
| X-Debian-User | carnil |
| X-Debian-Message | from BTS |
| X-Mailing-List | <debian-bugs-dist@lists.debian.org> archive/latest/1899324 |
| List-ID | <debian-bugs-dist.lists.debian.org> |
| List-URL | <https://lists.debian.org/debian-bugs-dist/> |
| Approved | robomod@news.nic.it |
| Lines | 62 |
| Organization | linux.* mail to news gateway |
| Sender | robomod@news.nic.it |
| X-Original-Date | Mon, 14 Apr 2025 18:00:26 +0200 |
| X-Original-Message-ID | <Z_0xGhGLhn0UcqZj@eldamar.lan> |
| X-Original-References | <174464002461.9739.11935813354960715701.reportbug@files.ad.davidsoncj.id.au> <174464002461.9739.11935813354960715701.reportbug@files.ad.davidsoncj.id.au> |
| Xref | csiph.com linux.debian.bugs.dist:1242012 linux.debian.kernel:86889 |
Cross-posted to 2 groups.
Show key headers only | View raw
Control: forcemerge 1103153 -1 Hi On Tue, Apr 15, 2025 at 12:13:44AM +1000, Cameron Davidson wrote: > Package: src:linux > Version: 6.1.133-1 > Severity: normal > > Dear Maintainer, > > > I recently carried out an upgrade to a home server running Debian > It is a VM host with 3 guest VMs. > One guest is Debian 11, the Dom0 and 2 other guests are Debian 12.10. > On April 13 I upgraded the various kernel packages on all 3 Debian 12 > systems to version 6.1.0-33-amd64 and rebooted. > It also upgraded the usbip package to 2.0+6.1.133-1 (but it is not > currently in use) > > On reboot, the Dom0 host system came up as expected, as did the > Debian 11 guest. Neither VM guest running the new kernel came up, > however it is possible that the mail gateway server failed because > of a dependency on the other. (At that stage "up" was defined as > responding to ssh login). > Later tests showed that the mail gateway can boot either kernel 6.1.0-32 > or 6.1.0-32 with equally good results. > The same cannot be said for the main guest VM. It consistently boots the > old kernel OK, but invariably fails with 6.1.0-33. > * I guess the source of the problem might be that I use PCI-passthrough > to provide the non-working VM with the xHCI USB controller > * after quite a few minutes it finishes the boot process without > attaching a root file system. (So of course nothing works and there is > no saved log) - It only "finishes" because everything times out. > * I was able to log the terminal text to capture the boot messages, > which I did for both working and non-working systems. Only the > non-working version is included below. > * Comparing the good and bad logs show only trivial differences such as > timing and sizes until it reaches the point of starting systemd-udevd > at (1.37s) > * At that point you see "BUG", "Oops" and a stack trace. > > The part of the xen config file relating to PCI passthrough simply has > pci = [ > '00:14.0' > ] > > > There is an initial error that appears in the host system and says: > "libxl: error: libxl_pci.c:1573:libxl__device_pci_reset: The kernel > doesn't support reset from sysfs for PCI device 0000:00:14.0" > and has been present for a long time. It does not seem to have any > negative consequence. > > The capture from the ssh session during the failed boot is as follows I believe the same root cause as #1102889. Merging the two bugs. Regards, Salvatore
Back to linux.debian.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
Bug#1103153: linux-image-6.1.0-33-amd64: kernel fails to boot in xen DomU with pci-passthrough Cameron Davidson <bugs@davidsoncj.id.au> - 2025-04-14 16:50 +0200 Bug#1103153: linux-image-6.1.0-33-amd64: kernel fails to boot in xen DomU with pci-passthrough Salvatore Bonaccorso <carnil@debian.org> - 2025-04-14 18:10 +0200 Processed: Re: Bug#1103153: linux-image-6.1.0-33-amd64: kernel fails to boot in xen DomU with pci-passthrough "Debian Bug Tracking System" <owner@bugs.debian.org> - 2025-04-14 18:10 +0200
csiph-web