Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.debian.kernel > #85066

Bug#1092495: linux-image-amd64: xz compression incompatible with Xen/pygrub

From Richard <rrosner5@gmail.com>
Newsgroups linux.debian.bugs.dist, linux.debian.kernel
Subject Bug#1092495: linux-image-amd64: xz compression incompatible with Xen/pygrub
Date 2025-01-09 19:10 +0100
Message-ID <K358J-70v3-11@gated-at.bofh.it> (permalink)
References <K2HSN-6Gsv-5@gated-at.bofh.it>
Organization linux.* mail to news gateway

Cross-posted to 2 groups.

Show all headers | View raw


I've just noticed, 6.11.7 already has this option enabled, yet it boot fine. So whatever change was introduced, when trying to boot the VM with xl top, these were the error messages produced:


Waiting for domain ts (domid 2) to die [pid 2645]
Domain 2 has shut down, reason code 1 0x1
Action for shutdown reason code 1 is restart
Domain 2 needs to be cleaned up: destroying the domain
Done. Rebooting now
xc: error: panic: xg_dom_bzimageloader.c:761: xc_dom_probe_bzimage_kernel unable to XZ decompress kernel: Invalid kernel
xc: error: panic: xg_dom_core.c:689: xc_dom_find_loader: no loader found: Invalid kernel
libxl: error: libxl_dom.c:571:libxl__build_dom: xc_dom_parse_image failed
libxl: error: libxl_create.c:1640:domcreate_rebuild_done: Domain 5:cannot (re-)build domain: -3
libxl: error: libxl_domain.c:1183:libxl__destroy_domid: Domain 5:Non-existant domain
libxl: error: libxl_domain.c:1137:domain_destroy_callback: Domain 5:Unable to destroy guest
libxl: error: libxl_domain.c:1064:domain_destroy_cb: Domain 5:Destruction of domain failed


The only way I could find to solve this was chroot into the image of the VM, uninstall the 6.12 Kernel and run update-grub. Hope this helps finding the issue.

Back to linux.debian.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread


Thread

Bug#1092495: linux-image-amd64: xz compression incompatible with Xen/pygrub Richard <rrosner5@gmail.com> - 2025-01-08 18:20 +0100
  Bug#1092495: linux-image-amd64: xz compression incompatible with Xen/pygrub Richard <rrosner5@gmail.com> - 2025-01-09 19:10 +0100

csiph-web