Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.debian.bugs.dist > #1231846 > unrolled thread
| Started by | Christian Marillat <marillat@debian.org> |
|---|---|
| First post | 2025-02-05 11:20 +0100 |
| Last post | 2025-02-06 17:40 +0100 |
| Articles | 2 — 1 participant |
Back to article view | Back to linux.debian.bugs.dist
This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by
below is the oldest one visible, not the original post.
Bug#1095206: distcc service fails to start: error "--nice: invalid numeric value" Christian Marillat <marillat@debian.org> - 2025-02-05 11:20 +0100
Bug#1095206: distcc service fails to start: error "--nice: invalid numeric value" Christian Marillat <marillat@debian.org> - 2025-02-06 17:40 +0100
| From | Christian Marillat <marillat@debian.org> |
|---|---|
| Date | 2025-02-05 11:20 +0100 |
| Subject | Bug#1095206: distcc service fails to start: error "--nice: invalid numeric value" |
| Message-ID | <KcKFH-eyVk-3@gated-at.bofh.it> |
On 05 févr. 2025 10:19, Alban Browaeys <prahal@yahoo.com> wrote: > Package: distcc > Version: 3.4+really3.4-9+b1 > Severity: normal > > Dear Maintainer, > The distcc service fails to start and error out with > "distccd[1242226]: ERROR: --nice: invalid numeric value" > > My /etc/default/distcc is vanilla from debian. > The error is misleading because changing JOBS="" to JOBS="200" in > /etc/default/distcc fixes distcc service startup > I clue it was JOBS being empty that was at faul tbecause I tried running > the dameon on the cli with the service default argument values and got: [...] > -- debconf information: > distcc/daemon-zeroconf: false > distcc/daemon-listen: 127.0.0.1 > distcc/daemon-allow: 127.0.0.1 > distcc/daemon-nice: 10 > distcc/daemon-jobs: > distcc/daemon: false distcc configuration is managed by debconf. You must reconfigure this package with sudo dpkg-reconfigure distcc I'll upload a new package with 10 as daemon-jobs default. I added comments in /etc/default/distcc to use dpkg-reconfigure to configure distcc Christian
[toc] | [next] | [standalone]
| From | Christian Marillat <marillat@debian.org> |
|---|---|
| Date | 2025-02-06 17:40 +0100 |
| Message-ID | <Kdd4Z-eSk9-7@gated-at.bofh.it> |
| In reply to | #1231846 |
On 06 févr. 2025 17:26, Alban Browaeys <prahal@yahoo.com> wrote: [...] >> distcc configuration is managed by debconf. >> >> You must reconfigure this package with >> >> sudo dpkg-reconfigure distcc >> >> I'll upload a new package with 10 as daemon-jobs default. >> >> I added comments in /etc/default/distcc to use dpkg-reconfigure to >> configure distcc > > > That was fast, thanks! > > Maybe a note in the package NEWS.Debian is more common than a comment > in the /etc/default file? > Or maybe both. Nothing new here. debconf configuration was already in distcc when I started to be the maintainer in 2018 Christian
[toc] | [prev] | [standalone]
Back to top | Article view | linux.debian.bugs.dist
csiph-web