Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.debian.bugs.dist > #1224398 > unrolled thread
| Started by | InterLinked <debian@phreaknet.org> |
|---|---|
| First post | 2024-12-17 03:20 +0100 |
| Last post | 2024-12-20 16:40 +0100 |
| Articles | 5 — 4 participants |
Back to article view | Back to linux.debian.bugs.dist
Bug#1090340: cdrom: Debian 12 missing drivers for HyperV 2008 R2 InterLinked <debian@phreaknet.org> - 2024-12-17 03:20 +0100
Bug#1090340: cdrom: Debian 12 missing drivers for HyperV 2008 R2 Cyril Brulebois <kibi@debian.org> - 2024-12-17 07:10 +0100
Bug#1090340: cdrom: Debian 12 missing drivers for HyperV 2008 R2 Ben Hutchings <ben@decadent.org.uk> - 2024-12-25 01:30 +0100
Bug#1090340: cdrom: Debian 12 missing drivers for HyperV 2008 R2 Cyril Brulebois <kibi@debian.org> - 2024-12-19 10:40 +0100
Bug#1090340: cdrom: Debian 12 missing drivers for HyperV 2008 R2 Bastian Blank <waldi@debian.org> - 2024-12-20 16:40 +0100
| From | InterLinked <debian@phreaknet.org> |
|---|---|
| Date | 2024-12-17 03:20 +0100 |
| Subject | Bug#1090340: cdrom: Debian 12 missing drivers for HyperV 2008 R2 |
| Message-ID | <JUvlL-7Ax-1@gated-at.bofh.it> |
Package: cdrom Severity: important Tags: d-i Dear Maintainer, The Debian 12 installer (any minor version) fails to install on HyperV on Windows Server 2008 R2. For demonstration purposes, I am using the debian-12.6.0-amd64-netinst ISO installer. Debian 12 installs on HyperV in Windows Server 2019, and Debian 11 (any version) also installs successfully in HyperV on Windows Server 2008 R2. Therefore, the issue seems to be limited to a regression within the Debian 12 installer itself. Issues are as follows: * Detect network hardware step fails with the default network adapter in HyperV. "No Ethernet card was detected. If you know the name of the driver needed by your Ethernet card, you can select from the list". No selection made causes it to work, the installer keeps cycling back to this step. * Removing the Network Adapter and adding a Legacy Network Adapter allows the network adapter to be detected successfully. However, a similar failure now occurs at "Detect disks". "No disk drive was detected. If you know the name of the driver needed by your disk drive, you can select it from the list..."
[toc] | [next] | [standalone]
| From | Cyril Brulebois <kibi@debian.org> |
|---|---|
| Date | 2024-12-17 07:10 +0100 |
| Message-ID | <JUyWl-a0T-1@gated-at.bofh.it> |
| In reply to | #1224398 |
[Multipart message — attachments visible in raw view] — view raw
Hi, and thanks for your report. InterLinked <debian@phreaknet.org> (2024-12-16): > The Debian 12 installer (any minor version) fails to install on HyperV > on Windows Server 2008 R2. For demonstration purposes, I am using the > debian-12.6.0-amd64-netinst ISO installer. > > Debian 12 installs on HyperV in Windows Server 2019, and Debian 11 (any > version) also installs successfully in HyperV on Windows Server 2008 R2. > Therefore, the issue seems to be limited to a regression within the > Debian 12 installer itself. > > Issues are as follows: > > * Detect network hardware step fails with the default network adapter > in HyperV. "No Ethernet card was detected. If you know the name of > the driver needed by your Ethernet card, you can select from the list". > No selection made causes it to work, the installer keeps cycling > back to this step. > * Removing the Network Adapter and adding a Legacy Network Adapter > allows the network adapter to be detected successfully. However, > a similar failure now occurs at "Detect disks". "No disk drive was > detected. If you know the name of the driver needed by your disk drive, > you can select it from the list..." Do you happen to know the names of the Linux kernel modules that'd be required to support those devices? You could try and run a Debian Live image to check whether kernel support is missing entirely (from the Linux kernel packages) or “just” from within the installer. Cheers, -- Cyril Brulebois (kibi@debian.org) <https://debamax.com/> D-I release manager -- Release team member -- Freelance Consultant
[toc] | [prev] | [next] | [standalone]
| From | Ben Hutchings <ben@decadent.org.uk> |
|---|---|
| Date | 2024-12-25 01:30 +0100 |
| Message-ID | <JXnrH-28oy-1@gated-at.bofh.it> |
| In reply to | #1224406 |
[Multipart message — attachments visible in raw view] — view raw
On Tue, 2024-12-17 at 07:06 +0100, Cyril Brulebois wrote:
> Hi,
>
> and thanks for your report.
>
> InterLinked <debian@phreaknet.org> (2024-12-16):
> > The Debian 12 installer (any minor version) fails to install on HyperV
> > on Windows Server 2008 R2. For demonstration purposes, I am using the
> > debian-12.6.0-amd64-netinst ISO installer.
> >
> > Debian 12 installs on HyperV in Windows Server 2019, and Debian 11 (any
> > version) also installs successfully in HyperV on Windows Server 2008 R2.
> > Therefore, the issue seems to be limited to a regression within the
> > Debian 12 installer itself.
[...]
Note that this hypervisor has been completely unsupported by MS for
nearly 5 years:
<https://learn.microsoft.com/en-us/lifecycle/products/hyperv-server-2008-r2>.
Most likely the Hyper-V drivers in Linux no longer support it. I don't
think this is worth spending time on.
Ben.
--
Ben Hutchings
Usenet is essentially a HUGE group of people passing notes in class.
- Rachel Kadel, `A Quick Guide to Newsgroup Etiquette'
[toc] | [prev] | [next] | [standalone]
| From | Cyril Brulebois <kibi@debian.org> |
|---|---|
| Date | 2024-12-19 10:40 +0100 |
| Message-ID | <JVlaF-QQy-11@gated-at.bofh.it> |
| In reply to | #1224398 |
[Multipart message — attachments visible in raw view] — view raw
InterLinked <debian@phreaknet.org> (2024-12-17): > I gave the live CD for 12.8 a try and it seems to work. I got > "hv_vmbus unable to connect to host" during boot and it hung for a > while, but eventually I got a shell prompt, so it seemed to figure it > out eventually (this was with the Legacy Network Adapter). I also > tried this with the regular Network Adapter, see the same messages, > and also get a prompt. Please share the output of `lsmod` from Debian Live, with the default (non-legacy) network adapter. `dmesg` might be helpful too. Thanks already! Cheers, -- Cyril Brulebois (kibi@debian.org) <https://debamax.com/> D-I release manager -- Release team member -- Freelance Consultant
[toc] | [prev] | [next] | [standalone]
| From | Bastian Blank <waldi@debian.org> |
|---|---|
| Date | 2024-12-20 16:40 +0100 |
| Message-ID | <JVNgB-18hu-3@gated-at.bofh.it> |
| In reply to | #1224398 |
On Mon, Dec 16, 2024 at 09:02:36PM -0500, InterLinked wrote: > The Debian 12 installer (any minor version) fails to install on HyperV > on Windows Server 2008 R2. For demonstration purposes, I am using the > debian-12.6.0-amd64-netinst ISO installer. Windows Server 2008 R2 is EOL since a few years. Bastian -- Well, Jim, I'm not much of an actor either.
[toc] | [prev] | [standalone]
Back to top | Article view | linux.debian.bugs.dist
csiph-web