Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.debian.bugs.dist > #1197903 > unrolled thread

Bug#1069065: gcc-14: should -for-host builds move from cross-toolchain build to DEB_STAGE=rtlibs?

Started byTimo Röhling <roehling@debian.org>
First post2024-05-19 10:10 +0200
Last post2024-05-19 10:10 +0200
Articles 1 — 1 participant

Back to article view | Back to linux.debian.bugs.dist

This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by below is the oldest one visible, not the original post.


Contents

  Bug#1069065: gcc-14: should -for-host builds move from cross-toolchain build to DEB_STAGE=rtlibs? Timo Röhling <roehling@debian.org> - 2024-05-19 10:10 +0200

#1197903 — Bug#1069065: gcc-14: should -for-host builds move from cross-toolchain build to DEB_STAGE=rtlibs?

FromTimo Röhling <roehling@debian.org>
Date2024-05-19 10:10 +0200
SubjectBug#1069065: gcc-14: should -for-host builds move from cross-toolchain build to DEB_STAGE=rtlibs?
Message-ID<IFJMd-en2i-9@gated-at.bofh.it>

[Multipart message — attachments visible in raw view] — view raw

Hi,

On Mon, 15 Apr 2024 18:10:16 +0200 Helmut Grohne <helmut@subdivi.de> 
wrote:
> Which gcc builds should emit -for-host packages?
> [...]
> I have added this patch to rebootstrap now and it has generally 
> improved bootstrapping. In particular, gcc-N-for-host is 
> practically coinstallable.
I find your reasoning convincing and had a look at the patch. The 
patch also looks reasonably sane to me. There is a typo near the end 
("disbaled" instead of "disabled"), which does not influence runtime 
behavior because the variable is only checked for equality with 
"yes".

Moving build logic to binary-forhost.mk gets rid of quite a lot of 
code duplication (the do_for_host_package macro becomes the 
authoritative source), which I consider a Good Thing. Ultimately, it 
is the maintainer's judgement call whether they want it like this or 
would rather change the conditional inclusion logic to have the 
-for-host package build logic reside with the respective language 
addon Makefiles.


Cheers
Timo

-- 
⢀⣴⠾⠻⢶⣦⠀   ╭────────────────────────────────────────────────────╮
⣾⠁⢠⠒⠀⣿⡁   │ Timo Röhling                                       │
⢿⡄⠘⠷⠚⠋⠀   │ 9B03 EBB9 8300 DF97 C2B1  23BF CC8C 6BDD 1403 F4CA │
⠈⠳⣄⠀⠀⠀⠀   ╰────────────────────────────────────────────────────╯

[toc] | [standalone]


Back to top | Article view | linux.debian.bugs.dist


csiph-web