Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.debian.bugs.dist > #1020094 > unrolled thread

Bug#966687: libselinux1-dev should be named libselinux-dev

Started byHelmut Grohne <helmut@subdivi.de>
First post2020-08-01 22:40 +0200
Last post2020-08-01 22:40 +0200
Articles 1 — 1 participant

Back to article view | Back to linux.debian.bugs.dist


Contents

  Bug#966687: libselinux1-dev should be named libselinux-dev Helmut Grohne <helmut@subdivi.de> - 2020-08-01 22:40 +0200

#1020094 — Bug#966687: libselinux1-dev should be named libselinux-dev

FromHelmut Grohne <helmut@subdivi.de>
Date2020-08-01 22:40 +0200
SubjectBug#966687: libselinux1-dev should be named libselinux-dev
Message-ID<Az6sq-4Pp-13@gated-at.bofh.it>

[Multipart message — attachments visible in raw view] — view raw

Package: libselinux1-dev
Version: 3.1-2
User: helmutg@debian.org
Usertags: rebootstrap
Tags: patch

Development packages should not include a version. For that reason
libselinux1-dev also provides libselinux-dev. Downstream packages such
as sed correctly build depend on the unversioned libselinux-dev.

Unfortunately, there is no reliable way to determine which source
package provides libselinux-dev from looking at the .dsc files.
Therefore bootstrapping tools fail to figure out that libselinux needs
to be built for building sed. The information included in .dscs misses
provides. For packages that participate in the build closure of
essential, we need dependencies to target real packages.

Therefore libselinux-dev needs to become real. I think that renaming
libselinux1-dev to libselinux-dev and simultaneously switching the
provides to libselinux1-dev would do the trick with little risk of
disrupting others.

I'm attaching a patch for the proposed change. Do you see any
alternative solution?

Helmut

[toc] | [standalone]


Back to top | Article view | linux.debian.bugs.dist


csiph-web