Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.debian.bugs.dist > #1270448
| From | Andrea Bolognani <eof@kiyuko.org> |
|---|---|
| Newsgroups | linux.debian.bugs.dist |
| Subject | Bug#1120807: [Pkg-libvirt-maintainers] Bug#1120807: virt-install: fails to create ppc64el machines due to page size choice |
| Date | 2025-11-16 23:20 +0100 |
| Message-ID | <LRTgd-dutQ-1@gated-at.bofh.it> (permalink) |
| References | <LROzT-drv1-1@gated-at.bofh.it> <LROzT-drv1-1@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
[Multipart message — attachments visible in raw view] - view raw
On Sun, Nov 16, 2025 at 08:20:31AM +0100, Helmut Grohne wrote:
> Package: virt-install
> Version: 1:5.0.0-5+deb13u1
> X-Debbugs-Cc: debian-powerpc@lists.debian.org, mjt@debian.org
> User: debian-powerpc@lists.debian.org
> Usertags: ppc64el
>
> Hello,
>
> I tried using virt-install to create a ppc64el kvm virtual machine. This
> fails with an error relayed from qemu:
>
> | Can't support 64 kiB guest pages with 4 kiB host pages with this KVM implementation
>
> The default machine used by virt-install for ppc64el is "pseries" and it
> appears to default to 64 kiB guest pages. Debian has changed (#1074217)
> the kernel's page size to 4 kiB for trixie though, so that's what Debian
> hosts typically use.
>
> On the qemu side, we may change this by passing:
>
> -machine pseries,cap-hpt-max-page-size=4096
>
> Now getting this option through virt-install is not obvious. Trying to
> pass a machine with an option to virt-install's --machine option results
> in a failure as it interprets the combination of machine and option as
> the machine and has no clue about this machine.
>
> A workaround here is passing it as a --qemu-commandline.
>
> --machine=pseries "--qemu-commandline=-machine pseries,cap-hpt-max-page-size=4096"
>
> Would it be possible for virt-install to support this use case in a more
> convenient way? For instance, it could detect the host's page size and
> adjust it itself or it could enable passing such options via --machine.
>
> Thanks for considering
So, a few things.
First of all, libvirt already exposes this capability: use
<domain>
<features>
<hpt>
<maxpagesize unit='KiB'>4</maxpagesize>
...
to configure it.
virt-install doesn't seem to support manipulating this value
directly though, at least based on the output of
$ virt-install --features help
so an upstream RFE will need to be filed to make that happen.
Taking a step back though, shouldn't QEMU default to a 4k page size
when 64k cannot work on the host?
Maybe there's something in the sPAPR spec that mandates 64k as the
default, I don't know. That would be very unfortunate. Users should
really not need to be aware of this kind of detail just to get a
basic VM going.
--
Andrea Bolognani <eof@kiyuko.org>
Resistance is futile, you will be garbage collected.
Back to linux.debian.bugs.dist | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
Bug#1120807: virt-install: fails to create ppc64el machines due to page size choice Helmut Grohne <helmut@subdivi.de> - 2025-11-16 18:20 +0100
Bug#1120807: [Pkg-libvirt-maintainers] Bug#1120807: virt-install: fails to create ppc64el machines due to page size choice Andrea Bolognani <eof@kiyuko.org> - 2025-11-16 23:20 +0100
Bug#1120807: virt-install: fails to create ppc64el machines due to page size choice Bastian Blank <waldi@debian.org> - 2025-11-18 08:10 +0100
Bug#1107288: Bug#1120807: virt-install: fails to create ppc64el machines due to page size choice Helmut Grohne <helmut@subdivi.de> - 2025-11-18 10:20 +0100
Bug#1107288: [Pkg-libvirt-maintainers] Bug#1120807: virt-install: fails to create ppc64el machines due to page size choice Andrea Bolognani <eof@kiyuko.org> - 2025-11-19 02:50 +0100
csiph-web