Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.debian.bugs.dist > #1227505

Bug#1032495: kea-dhcp4-server fails to start on sysv

From David Burgess <david@burgess.tech>
Newsgroups linux.debian.bugs.dist
Subject Bug#1032495: kea-dhcp4-server fails to start on sysv
Date 2025-01-08 22:30 +0100
Message-ID <K2LMJ-6IXI-1@gated-at.bofh.it> (permalink)
References <G6TKN-aVDY-1@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


Debian 12.8
kea-common 2.2.0-6
kea-dhcp4-server 2.2.0-6
sysvinit-core 3.06-4

My config file tests without error, but I get the same errors as OP when 
trying to run kea-dhcp4-server as user _kea. I am able to test fixes on 
sysv.

_kea@cid2004-dhcp-01:/etc/kea$ kea-dhcp4 -t kea-dhcp4.conf
2025-01-08 16:05:47.694 INFO  [kea-dhcp4.hosts/5214.140580725867008] 
HOSTS_BACKENDS_REGISTERED the following host backend types are 
available: mysql postgresql
2025-01-08 16:05:47.695 INFO  [kea-dhcp4.dhcpsrv/5214.140580725867008] 
DHCPSRV_CFGMGR_SOCKET_TYPE_SELECT using socket type raw
2025-01-08 16:05:47.695 INFO  [kea-dhcp4.dhcpsrv/5214.140580725867008] 
DHCPSRV_CFGMGR_NEW_SUBNET4 a new subnet has been added to configuration: 
a.b.c.0/27 with params: t1=900, t2=1800, valid-lifetime=3600
2025-01-08 16:05:47.695 INFO  [kea-dhcp4.dhcpsrv/5214.140580725867008] 
DHCPSRV_CFGMGR_NEW_SUBNET4 a new subnet has been added to configuration: 
x.y.z.128/26 with params: t1=900, t2=1800, valid-lifetime=3600

_kea@cid2004-dhcp-01:/etc/kea$ kea-dhcp4 -c kea-dhcp4.conf
Unable to use interprocess sync lockfile (Permission denied): 
/var/run/kea/logger_lockfile
Unable to use interprocess sync lockfile (Permission denied): 
/var/run/kea/logger_lockfile
Unable to use interprocess sync lockfile (Permission denied): 
/var/run/kea/logger_lockfile
Unable to use interprocess sync lockfile (Permission denied): 
/var/run/kea/logger_lockfile
Unable to use interprocess sync lockfile (Permission denied): 
/var/run/kea/logger_lockfile
Unable to use interprocess sync lockfile (Permission denied): 
/var/run/kea/logger_lockfile
Unable to use interprocess sync lockfile (Permission denied): 
/var/run/kea/logger_lockfile
Unable to use interprocess sync lockfile (Permission denied): 
/var/run/kea/logger_lockfile
Unable to use interprocess sync lockfile (Permission denied): 
/var/run/kea/logger_lockfile
Unable to use interprocess sync lockfile (Permission denied): 
/var/run/kea/logger_lockfile
Unable to use interprocess sync lockfile (Permission denied): 
/var/run/kea/logger_lockfile

root@cid2004-dhcp-01:/etc/kea# dmesg|tail
[87850.223904] audit: type=1400 audit(1736370353.041:61): 
apparmor="DENIED" operation="mknod" profile="kea-dhcp4" 
name="/run/kea/logger_lockfile" pid=5219 comm="kea-dhcp4" 
requested_mask="c" denied_mask="c" fsuid=105 ouid=105
[87850.225122] audit: type=1400 audit(1736370353.041:62): 
apparmor="DENIED" operation="mknod" profile="kea-dhcp4" 
name="/run/kea/logger_lockfile" pid=5219 comm="kea-dhcp4" 
requested_mask="c" denied_mask="c" fsuid=105 ouid=105
[87850.225487] audit: type=1400 audit(1736370353.041:63): 
apparmor="DENIED" operation="mknod" profile="kea-dhcp4" 
name="/run/kea/logger_lockfile" pid=5219 comm="kea-dhcp4" 
requested_mask="c" denied_mask="c" fsuid=105 ouid=105
[87850.225646] audit: type=1400 audit(1736370353.041:64): 
apparmor="DENIED" operation="mknod" profile="kea-dhcp4" 
name="/run/kea/logger_lockfile" pid=5219 comm="kea-dhcp4" 
requested_mask="c" denied_mask="c" fsuid=105 ouid=105
[87850.225904] audit: type=1400 audit(1736370353.041:65): 
apparmor="DENIED" operation="mknod" profile="kea-dhcp4" 
name="/run/kea/logger_lockfile" pid=5219 comm="kea-dhcp4" 
requested_mask="c" denied_mask="c" fsuid=105 ouid=105
[87850.226558] audit: type=1400 audit(1736370353.041:66): 
apparmor="DENIED" operation="mknod" profile="kea-dhcp4" 
name="/run/kea/logger_lockfile" pid=5219 comm="kea-dhcp4" 
requested_mask="c" denied_mask="c" fsuid=105 ouid=105
[87850.226717] audit: type=1400 audit(1736370353.041:67): 
apparmor="DENIED" operation="mknod" profile="kea-dhcp4" 
name="/run/kea/logger_lockfile" pid=5219 comm="kea-dhcp4" 
requested_mask="c" denied_mask="c" fsuid=105 ouid=105
[87850.227004] audit: type=1400 audit(1736370353.045:68): 
apparmor="DENIED" operation="mknod" profile="kea-dhcp4" 
name="/run/kea/logger_lockfile" pid=5219 comm="kea-dhcp4" 
requested_mask="c" denied_mask="c" fsuid=105 ouid=105
[87850.227172] audit: type=1400 audit(1736370353.045:69): 
apparmor="DENIED" operation="mknod" profile="kea-dhcp4" 
name="/run/kea/logger_lockfile" pid=5219 comm="kea-dhcp4" 
requested_mask="c" denied_mask="c" fsuid=105 ouid=105
[87850.227374] audit: type=1400 audit(1736370353.045:70): 
apparmor="DENIED" operation="mknod" profile="kea-dhcp4" 
name="/run/kea/logger_lockfile" pid=5219 comm="kea-dhcp4" 
requested_mask="c" denied_mask="c" fsuid=105 ouid=105

Back to linux.debian.bugs.dist | Previous | Next | Find similar | Unroll thread


Thread

Bug#1032495: kea-dhcp4-server fails to start on sysv David Burgess <david@burgess.tech> - 2025-01-08 22:30 +0100

csiph-web