Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.debian.bugs.dist > #1171306
| From | Liam K Morland <Liam@Morland.ca> |
|---|---|
| Newsgroups | linux.debian.bugs.dist |
| Subject | Bug#599063: pg_upgradecluster does not check if schema and data were properly upgraded |
| Date | 2023-10-10 02:40 +0200 |
| Message-ID | <Hn8WZ-eKEY-1@gated-at.bofh.it> (permalink) |
| References | <fzQCB-4bW-3@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
Package: postgresql-common Version: 255 Followup-For: Bug #599063 Dear Maintainer, It seems to me that the issue here is that even when the upgrade fails, pg_upgradecluster reports success and puts the new database into use. I am ran into this problem when upgrading from PG 15 to 16. An error in the upgrade created a broken database for a different reason than the original reporter of this bug, but pg_upgradecluster reported success. This was my PG bug report: https://www.postgresql.org/message-id/18151-cdc2191b130172c7%40postgresql.org My error was: pg_restore: error: could not execute query: ERROR: relation "event" does not exist An error like this should leave the old DB running and output an error message. Thanks, Liam -- System Information: Debian Release: trixie/sid APT prefers testing APT policy: (500, 'testing'), (500, 'stable'), (500, 'oldstable') Architecture: i386 (i686) Kernel: Linux 6.5.0-1-686-pae (SMP w/4 CPU threads; PREEMPT) Locale: LANG=en_CA.UTF-8, LC_CTYPE=en_CA.UTF-8 (charmap=UTF-8), LANGUAGE not set Shell: /bin/sh linked to /usr/bin/dash Init: systemd (via /run/systemd/system) Versions of packages postgresql-common depends on: ii adduser 3.137 ii debconf [debconf-2.0] 1.5.82 ii init-system-helpers 1.65.2 ii libjson-perl 4.10000-1 ii lsb-base 11.6 ii perl 5.36.0-9 ii postgresql-client-common 255 ii ssl-cert 1.1.2 ii sysvinit-utils [lsb-base] 3.08-1 ii ucf 3.0043+nmu1 Versions of packages postgresql-common recommends: ii e2fsprogs 1.47.0-2+b1 ii logrotate 3.21.0-1 postgresql-common suggests no packages. -- Configuration Files: /etc/postgresql-common/createcluster.conf changed [not included] -- debconf information: * postgresql-common/ssl: true * postgresql-common/obsolete-major: postgresql-common/catversion-bump:
Back to linux.debian.bugs.dist | Previous | Next | Find similar | Unroll thread
Bug#599063: pg_upgradecluster does not check if schema and data were properly upgraded Liam K Morland <Liam@Morland.ca> - 2023-10-10 02:40 +0200
csiph-web