Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.debian.bugs.dist > #1135954

Bug#1030292: Cannot bind to privileged port

From "Daniel Richard G." <skunk@iSKUNK.ORG>
Newsgroups linux.debian.bugs.dist
Subject Bug#1030292: Cannot bind to privileged port
Date 2023-02-02 06:40 +0100
Message-ID <FUAud-2PCy-1@gated-at.bofh.it> (permalink)
Organization linux.* mail to news gateway

Show all headers | View raw


Package: apt-cacher-ng
Version: 3.7.4-1+b2
Severity: important

I want to run apt-cacher-ng on port 80 for a dedicated caching server.

After configuring via debconf to use that port, and restarting, nothing
is listening at localhost:80. I see the following in syslog:

    2023-02-02T00:10:04.728949-05:00 image-debian64 systemd[1]: Starting apt-cacher-ng.service - Apt-Cacher NG software download proxy...
    2023-02-02T00:10:04.740737-05:00 image-debian64 apt-cacher-ng[668]: Couldn't bind socket: Permission denied
    2023-02-02T00:10:04.740858-05:00 image-debian64 apt-cacher-ng[668]: Couldn't bind socket: Permission denied
    2023-02-02T00:10:04.743750-05:00 image-debian64 systemd[1]: Started apt-cacher-ng.service - Apt-Cacher NG software download proxy.

If this is a limitation of the current package, then it should be noted
in the documentation and debconf prompt.


--Daniel


-- 
Daniel Richard G. || skunk@iSKUNK.ORG
My ASCII-art .sig got a bad case of Times New Roman.

Back to linux.debian.bugs.dist | Previous | Next | Find similar | Unroll thread


Thread

Bug#1030292: Cannot bind to privileged port "Daniel Richard G." <skunk@iSKUNK.ORG> - 2023-02-02 06:40 +0100

csiph-web