Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > comp.soft-sys.math.mathematica > #2889
| From | Szabolcs Horvát <szhorvat@gmail.com> |
|---|---|
| Newsgroups | comp.soft-sys.math.mathematica |
| Subject | Re: Mapping to Create Nested Loops |
| Date | 2011-06-02 11:16 +0000 |
| Organization | Steven M. Christensen and Associates, Inc and MathTensor, Inc. |
| Message-ID | <is7rdh$rf9$1@smc.vnet.net> (permalink) |
| References | <is57n9$dgk$1@smc.vnet.net> |
On 2011.06.01. 13:27, Bob Hanlon wrote: > GatherBy[myArray, #[[3]]&] > > GatherBy[#, #[[3]]&]& /@ myListOfArrays > > Is this kind of use of nested functions with # guaranteed to be safe (let's disregard readability concerns for now)? It appears that # indeed is always the argument of the innermost function, but I couldn't find this stated in the docs. Instead, it's suggested in the docs (page for Slot) to use named arguments with nested functions (but those aren't without name-conflict / localization issues either)
Back to comp.soft-sys.math.mathematica | Previous | Next — Previous in thread | Find similar | Unroll thread
Re: Mapping to Create Nested Loops Bob Hanlon <hanlonr@cox.net> - 2011-06-01 11:27 +0000 Re: Mapping to Create Nested Loops Szabolcs Horvát <szhorvat@gmail.com> - 2011-06-02 11:16 +0000
csiph-web