Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > comp.os.linux.networking > #1743 > unrolled thread

192.168

Started bybob@coolfone.comze.com
First post2012-10-17 08:37 -0700
Last post2012-10-18 06:40 +0200
Articles 8 on this page of 28 — 15 participants

Back to article view | Back to comp.os.linux.networking


Contents

  192.168 bob@coolfone.comze.com - 2012-10-17 08:37 -0700
    Re: 192.168 Richard Kettlewell <rjk@greenend.org.uk> - 2012-10-17 16:40 +0100
      Re: 192.168 ein <ein@no.spam> - 2012-10-17 20:04 +0200
        Re: 192.168 Marc Haber <mh+usenetspam1118@zugschl.us> - 2012-10-17 21:23 +0200
          Re: 192.168 ein <ein@no.spam> - 2012-10-17 22:37 +0200
            Re: 192.168 Marc Haber <mh+usenetspam1118@zugschl.us> - 2012-10-18 18:29 +0200
              Re: 192.168 ein <ein@no.spam> - 2012-10-19 07:54 +0200
    Re: 192.168 Maurizio Loreti <mlo@foobar.it> - 2012-10-17 20:37 +0200
    Re: 192.168 unruh <unruh@invalid.ca> - 2012-10-18 01:43 +0000
      Re: 192.168 Richard Kettlewell <rjk@greenend.org.uk> - 2012-10-18 09:22 +0100
        Re: 192.168 ein <ein@no.spam> - 2012-10-19 07:51 +0200
          Re: 192.168 Noob <root@127.0.0.1> - 2012-10-19 12:16 +0200
            Re: 192.168 orcus@pwr.wroc.pl - 2012-10-19 18:54 +0000
              Re: 192.168 Jorgen Grahn <grahn+nntp@snipabacken.se> - 2012-10-20 06:51 +0000
                Re: 192.168 orcus@pwr.wroc.pl - 2012-10-20 07:46 +0000
                  Re: 192.168 Jorgen Grahn <grahn+nntp@snipabacken.se> - 2012-10-20 08:00 +0000
                    Re: 192.168 orcus@pwr.wroc.pl - 2012-10-20 13:43 +0000
                      Re: 192.168 Jorgen Grahn <grahn+nntp@snipabacken.se> - 2012-10-20 14:15 +0000
                        Re: 192.168 orcus@pwr.wroc.pl - 2012-10-20 14:54 +0000
                          Re: 192.168 Moe Trin <ibuprofin@painkiller.example.tld.invalid> - 2012-10-20 15:21 -0500
                        Re: 192.168 Moe Trin <ibuprofin@painkiller.example.tld.invalid> - 2012-10-20 15:20 -0500
            Re: 192.168 Pascal Hambourg <boite-a-spam@plouf.fr.eu.org> - 2012-10-20 13:55 +0200
          Re: 192.168 unruh <unruh@invalid.ca> - 2012-10-21 00:33 +0000
            Re: 192.168 orcus@pwr.wroc.pl - 2012-10-21 10:22 +0000
              Re: 192.168 Markus Koßmann <mkossmann_n1@gmx.de> - 2012-10-21 15:53 +0200
            Re: 192.168 GangGreene <GangGreene@example.com> - 2012-10-21 07:06 -0400
    Re: 192.168 Vanni <Vanniz@nospam.thanks> - 2012-10-18 07:56 +0200
      Re: 192.168 Johann Klammer <klammerj@NOSPAM.a1.net> - 2012-10-18 06:40 +0200

Page 2 of 2 — ← Prev page 1 [2]


#1769

FromMoe Trin <ibuprofin@painkiller.example.tld.invalid>
Date2012-10-20 15:20 -0500
Message-ID<slrnk861rg.8ev.ibuprofin@fermi.phx.az.us>
In reply to#1766
On 20 Oct 2012, in the Usenet newsgroup comp.os.linux.networking, in article
<slrnk85cgf.1d3.grahn+nntp@frailea.sa.invalid>, Jorgen Grahn wrote:

>orcus@pwr.wroc.pl wrote:
>> Jorgen Grahn <grahn+nntp@snipabacken.se> wrote:
>>> orcus@pwr.wroc.pl wrote:

>>>> Nope - a lot of ISPs use privete adresses to connect their routers. 

IP addresses are valuable commodities - as of Monday, 93.66 percent of
the non-RFC5735 IPv4 addresses have been assigned or allocated.  Why
should an ISP waste them on hosts that normal users (never mind those
out on the Big Bad Internet) won't be accessing?  See the "Category 1:"
definition on the bottom of page 2 of RFC1918.

>>>> Sometimes we can see "non-routable" adsresses in output of
>>>> traceroute - somewere in "Internet".

>>> If an address shows up in traceroute output, I should be able to
>>> access it.

Why?  What gives you ANY reason to expect that "backbone.com" is going
to allow you to connect to their router?   It's not a web server, and
it's offering NO services to Internet users other than forwarding or
routing packets.

>> Which fragment fragment of RFC they violate?

Second paragraph on page 5 of RFC1918:

   Because private addresses have no global meaning, routing information
   about private networks shall not be propagated on inter-enterprise
   links, and packets with private source or destination addresses
   should not be forwarded across such links.

HOWEVER - note that RFC1918 is a "Best Current Practice" (see RFC1818
which is historic, but explains that a BCP is not, and should not be
considered "a standard").  Against this, you have RFC1812
(Requirements for IP Version 4 Routers) section 4.3.2.4 which says:

   Except where this document specifies otherwise, the IP source address
   in an ICMP message originated by the router MUST be one of the IP
   addresses associated with the physical interface over which the ICMP
   message is transmitted.

and RFC1812 _is_ a standard.

>You say you can see e.g. 192.168.1.2 in traceroute output.  That
>means you have actually received an ICMP time exceeded (or whatever
>it's called) message from that host.  Surely then it's not just
>"inside their network"?

True - but an ICMP error message is "one way" - you don't reply to it
(RFC0792, fourth paragraph of "Introduction" on bottom of page 1), so
a little common sense would be helpful.  Read the second paragraph of
section 7 of RFC5735.

>I may have a host 192.168.1.2 in my local network already. I cannot
>think right now of any bad effects of getting ICMP from a doppelganger
>(except for confusion in the logs) but I'd prefer for it never to
>happen!

See RFC2827 (and RFC3704).  Your router or firewall should not be
forwarding packets from the "outside" that have a source address of
the LAN on the "inside".  To avoid confusion, you may wish to filter
all of the addresses listed in RFC5735 (and RFC5156 if you are using
IPv6) as recommended by the first paragraph of of section 7 of RFC5735.

        Old guy

[toc] | [prev] | [next] | [standalone]


#1764

FromPascal Hambourg <boite-a-spam@plouf.fr.eu.org>
Date2012-10-20 13:55 +0200
Message-ID<k5u3gk$vmg$1@saria.nerim.net>
In reply to#1758
Hello,

Noob a écrit :
> ein wrote:
> 
>> unruh wrote:
>>
>>> And why would you want to memorize it? That is a private address
>>> reange, non-routable on the internet.
>> IMHO there's no such thing like non-routable IP address range,

There are : link-local scope addresses such as 169.254.0.0/16 or
fe80::/10 are non routable, i.e. they should not be forwarded by any
router on either private or public networks.
But when Unruh wrote "non-routable on the internet", I guess it meant
the public internet.

> The address ranges defined in RFC1918 are non-routable by definition.

No. Private addresses are perfectly routable on a private network. They
should just not be routed on the public internet across separate networks.

[toc] | [prev] | [next] | [standalone]


#1772

Fromunruh <unruh@invalid.ca>
Date2012-10-21 00:33 +0000
Message-ID<fpHgs.921$rn3.646@newsfe13.iad>
In reply to#1756
On 2012-10-19, ein <ein@no.spam> wrote:
>
> Richard Kettlewell wrote:
>> unruh <unruh@invalid.ca> writes:
>>> On 2012-10-17, bob@coolfone.comze.com <bob@coolfone.comze.com>
>>> wrote:
>> 
>>>> Why is it that almost all LAN devices start with 192.168?  Why
>>>> such a strange and hard-to-memorize number?
>>> 
>>> And why would you want to memorize it? That is a private address
>>> reange, non-routable on the internet.
>
> IMHO there's no such thing like non-routable IP address range, but

Yes, there is since many routers/switches whatever on the internet are
sesigned to throw away any packets addressed to those private addresses,
since there is no way that they can be routed outside the private
network itself. There are many many machines in th eworld with address
say 192.168.1.5 Which one should be chosen?



> more safe definition would be that private IP address ranges should be
> excluded (filtred) in the Internet. Common ISPs mistake is that
> private ranges are in routing tables or even announced by their BGP
> routers.
>
>

[toc] | [prev] | [next] | [standalone]


#1773

Fromorcus@pwr.wroc.pl
Date2012-10-21 10:22 +0000
Message-ID<slrnk87j3j.pn1.orcus@orcus.wcss.wroc.pl>
In reply to#1772
On 2012-10-21, unruh <unruh@invalid.ca> wrote:
> On 2012-10-19, ein <ein@no.spam> wrote:
>>
>> Richard Kettlewell wrote:
>>> unruh <unruh@invalid.ca> writes:
>>>> On 2012-10-17, bob@coolfone.comze.com <bob@coolfone.comze.com>
>>>> wrote:
>>> 
>>>>> Why is it that almost all LAN devices start with 192.168?  Why
>>>>> such a strange and hard-to-memorize number?
>>>> 
>>>> And why would you want to memorize it? That is a private address
>>>> reange, non-routable on the internet.
>>
>> IMHO there's no such thing like non-routable IP address range, but
>
> Yes, there is since many routers/switches whatever on the internet are
> sesigned to throw away any packets addressed to those private addresses,
> since there is no way that they can be routed outside the private
> network itself. There are many many machines in th eworld with address
> say 192.168.1.5 Which one should be chosen?

If some decided not to eat apples then we should call all apples
"un-eatable"?  

In my network I have 10 networks 10.[0-10].0.0/16 and a router
connecting them. Am I able to set up routing for these subnets? 
That range is clearly "routable".

-- 
Pozdrawiam
orcus

[toc] | [prev] | [next] | [standalone]


#1775

FromMarkus Koßmann <mkossmann_n1@gmx.de>
Date2012-10-21 15:53 +0200
Message-ID<aei5u6F5m1rU1@mid.individual.net>
In reply to#1773
orcus@pwr.wroc.pl wrote:


> In my network I have 10 networks 10.[0-10].0.0/16 and a router
> connecting them. Am I able to set up routing for these subnets?
> That range is clearly "routable".
> 
Well, RFC1918 says:

3. Private Address Space


   The Internet Assigned Numbers Authority (IANA) has reserved the
   following three blocks of the IP address space for private internets:

     10.0.0.0        -   10.255.255.255  (10/8 prefix)
     172.16.0.0      -   172.31.255.255  (172.16/12 prefix)
     192.168.0.0     -   192.168.255.255 (192.168/16 prefix)
[...]
So you are free to setup whatever routing you want inbetween your private 
subnet(s). But every connection from one of your subnets to the "non-
private" internet has to use NAT (like connections from the 192.168.x.x 
range)   

[toc] | [prev] | [next] | [standalone]


#1774

FromGangGreene <GangGreene@example.com>
Date2012-10-21 07:06 -0400
Message-ID<2i1dl9-97l.ln1@crazy-horse.bildanet.com>
In reply to#1772
On Sun, 21 Oct 2012 00:33:15 +0000, unruh wrote:

> On 2012-10-19, ein <ein@no.spam> wrote:
>>
>> Richard Kettlewell wrote:
>>> unruh <unruh@invalid.ca> writes:
>>>> On 2012-10-17, bob@coolfone.comze.com <bob@coolfone.comze.com> wrote:
>>> 
>>>>> Why is it that almost all LAN devices start with 192.168?  Why such
>>>>> a strange and hard-to-memorize number?
>>>> 
>>>> And why would you want to memorize it? That is a private address
>>>> reange, non-routable on the internet.
>>
>> IMHO there's no such thing like non-routable IP address range, but
> 
> Yes, there is since many routers/switches whatever on the internet are
> sesigned to throw away any packets addressed to those private addresses,
> since there is no way that they can be routed outside the private
> network itself. There are many many machines in th eworld with address
> say 192.168.1.5 Which one should be chosen?
> 
> 

The one in the arp table

[toc] | [prev] | [next] | [standalone]


#1750

FromVanni <Vanniz@nospam.thanks>
Date2012-10-18 07:56 +0200
Message-ID<507f7dfd$0$13280$4fafbaef@reader2.news.tin.it>
In reply to#1743
On 10/17/2012 05:37 PM, bob@coolfone.comze.com wrote:
> Why is it that almost all LAN devices start with 192.168?  Why such a strange and hard-to-memorize number?

this is a privat IP

[toc] | [prev] | [next] | [standalone]


#1751

FromJohann Klammer <klammerj@NOSPAM.a1.net>
Date2012-10-18 06:40 +0200
Message-ID<507f885b$0$18682$91cee783@newsreader03.highway.telekom.at>
In reply to#1750
Vanni wrote:
> On 10/17/2012 05:37 PM, bob@coolfone.comze.com wrote:
>> Why is it that almost all LAN devices start with 192.168? Why such a
>> strange and hard-to-memorize number?
>
> this is a privat IP

http://www.theregister.co.uk/2012/08/21/verity_stob_ipv6/

Sums it up pretty well.

[toc] | [prev] | [standalone]


Page 2 of 2 — ← Prev page 1 [2]

Back to top | Article view | comp.os.linux.networking


csiph-web