Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > comp.os.linux.networking > #1423

Re: how to route pings through arbitrary data centers to targets

Newsgroups comp.os.linux.networking
From Moe Trin <ibuprofin@painkiller.example.tld.invalid>
Subject Re: how to route pings through arbitrary data centers to targets
References <3e1b3edf-f4d2-4810-84bc-7022dbe8516a@googlegroups.com>
Message-ID <slrnjs5eba.7iq.ibuprofin@fermi.phx.az.us> (permalink)
Date 2012-05-27 18:31 -0500

Show all headers | View raw


On Sun, 27 May 2012, in the Usenet newsgroup comp.os.linux.networking,
in article <3e1b3edf-f4d2-4810-84bc-7022dbe8516a@googlegroups.com>,
LA Gary wrote:

NOTE: Posting from groups.google.com (or some web-forums) dramatically
reduces the chance of your post being seen.  Find a real news server.

>I'm more of a dev than a network guy, so pls pardon my naivete....

OK - it's a rather complex subject anyway.

>Basically, I want to determine how to have my 'remote ping' site find
>routes to a given domain, where these routes would be from far-flung
>data centers, so I can let the domain owner know how long it takes for
>the world to reach his/her site from wherever. And, I think I have
>seen sites with services like this to varying degrees, but I wanna do
>this myself or white label a service that does.

Long ago, in a galaxy far away, this _USED_TO_BE_ possible. It's no
longer likely, due to abuse.   It may or may not be useful, because
the route from a given host depends on what that host is connected to.
Example: a Road Runner host in the LA basin has one set of routes out,
and these will differ from a PacBell/ATT/SWBell host or a Comcast host
(never mind a host at USC or UCLA).  Note also that propagation times
may vary as a function of time and day, so be careful about comparing
apples with tomatoes or pinecones.

>I'd rather not buy a bunch of hosting accounts so i can get coverage
>from various associated data centers.

None the less, that's the most likely solution to work.  Content
provider companies such as Akamai have spent much coin to obtain this
type of data just so they can provide the most rapid response. They
also have servers (that provide data under contract) in many countries
(not just different cities) to do so.

>I assume (hope, really) there is some truly efficient, elegant way
>that just allows me to form some commands that I send out from my vps
>to achieve this.

  0791 Internet Protocol. J. Postel. September 1981. (Format: TXT=97779
       bytes) (Obsoletes RFC0760) (Updated by RFC1349) (Also STD0005)
       (Status: STANDARD)

RFC0791 page 16 identifies an IP option called "Source Routing" (more
details on pages 18 through 21).  That's the one that's ignored today.

>I use ping as an example, but if it is something else like traceroute
>or curl or something, that I could derive trip times from then that's
>fine.

You'd want something using TCP, not ICMP (ping or the microsoft version
of tracert) or UDP (the normal version of traceroute). Those protocols
are often handled with different priority, and _MAY_ use different
routes than TCP.  You may want to study the man page for traceroute
(and the similar "tcptraceroute") for background info.

        Old guy

Back to comp.os.linux.networking | Previous | Next — Previous in thread | Find similar | Unroll thread


Thread

how to route pings through arbitrary data centers to targets LA Gary <la.gary@gmail.com> - 2012-05-27 13:44 -0700
  Re: how to route pings through arbitrary data centers to targets Moe Trin <ibuprofin@painkiller.example.tld.invalid> - 2012-05-27 18:31 -0500

csiph-web