Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > comp.os.linux.networking > #2774
| Path | csiph.com!v102.xanadu-bbs.net!xanadu-bbs.net!usenet.blueworldhosting.com!feeder01.blueworldhosting.com!peer02.iad.highwinds-media.com!news.highwinds-media.com!feed-me.highwinds-media.com!spln!extra.newsguy.com!newsp.newsguy.com!news4 |
|---|---|
| From | buck <buck@private.mil> |
| Newsgroups | comp.os.linux.networking |
| Subject | Re: ping Moe Trin |
| Date | 6 Mar 2014 07:19:15 GMT |
| Organization | Say What? |
| Lines | 93 |
| Message-ID | <lf97hj0103q@news4.newsguy.com> (permalink) |
| References | <lf7toj01a8q@news6.newsguy.com> <53179ACA.6000006@thadlabs.com> <slrnlhf8fq.81f.grahn+nntp@frailea.sa.invalid> <slrnlhfl3f.cij.ibuprofin@fermi.phx.az.us> |
| NNTP-Posting-Host | p20264136e47121a22118c006057fa566e504241fd7c5c650.newsdawg.com |
| User-Agent | Xnews/5.04.25 |
| X-Received-Bytes | 4129 |
| X-Received-Body-CRC | 2011609731 |
| Xref | csiph.com comp.os.linux.networking:2774 |
Show key headers only | View raw
Moe Trin <ibuprofin@painkiller.example.tld.invalid> wrote in
news:slrnlhfl3f.cij.ibuprofin@fermi.phx.az.us:
> On 5 Mar 2014, in the Usenet newsgroup comp.os.linux.networking, in
> article <slrnlhf8fq.81f.grahn+nntp@frailea.sa.invalid>, Jorgen Grahn
> wrote:
>
>>Thad Floryan wrote:
>
>>> buck wrote:
>
>>>> I am searching for an RFC that says an Email header may contain a
>>>> blank SENDER. I'm sure I read that the SMTP server must not
reject
>>>> messages where the SENDER is blank, but darned if I can find it
>>>> now.
>
> I wonder if you are referring to section 6.4 of RFC5321. which is
sort
> of based on "The Robustness Principle" (see RFC1122 section 1.2.2)
> originally attributed to Jon Postal:
>
> "Be liberal in what you accept, and
> conservative in what you send"
>
>>> Googling "RFC that says an Email header may contain a blank
SENDER"
>>> without the quotes provides what you seek.
>
>>Which of the hits, and will the answer be "yes" or "no"? I'm asking
>>because his question is ambiguous: is he talking about the "Sender:"
>>header or about any header providing some kind of information about
>>the sender (From:, Sender:, possibly others)?
>
> I'll agree that the question is ambiguous. "Sender:" isn't a
> "required" header in all cases, and may be missing in many cases.
> "From:" on the other hand...
>
>>Personally I'd check RFC 5322 section 3.6.2.
>
> 6854 Update to Internet Message Format to Allow Group Syntax in
the
> "From:" and "Sender:" Header Fields. B. Leiba. March 2013.
> (Format: TXT=20190 bytes) (Updates RFC5322) (Status: PROPOSED
> STANDARD)
>
> Abstract
>
> The Internet Message Format (RFC 5322) allows "group" syntax in
> some email header fields, such as "To:" and "CC:", but not in
> "From:" or "Sender:". This document updates RFC 5322 to relax
that
> restriction, allowing group syntax in those latter fields, as
well
> as in "Resent-From:" and "Resent-Sender:", in certain situations.
>
> On the other hand,
>
> The Internet Message Format, as far back as RFC 822 [RFC0822],
has
> always required a usable address to appear in the "From:" header
> field of messages in order to allow replies to be sent. To this
> end, the syntax of messages, up to and including the current
> specification [RFC5322], has required the use of the mailbox
> address form in the originator ("From:" and "Sender:") fields of
> messages and has specifically forbidden the use of the group
> address form, which permits an empty list of addresses (that is,
an
> address list with no address included that might be used for a
> reply).
>
> However, the use cases for the "From:" field have evolved. There
> are numerous instances of automated systems that wish to send
email
> but cannot handle replies, and a "From:" field with no usable
> addresses would be extremely useful for that purpose.
>
> But you also want to look at the SMTP transaction (RFC5321, section
> 3.3) about the "MAIL FROM" dialog.
>
> So "buck", care to clarify the question?
>
> Old guy
>
Let me read the RFCs referenced in replies to my question, after which
I
will reply more carefully.
Meantime, from a moral standpoint I wish to insist that if the sender
refuses to identify that I may discard the message without having
violated any internet standard. --
buck
Back to comp.os.linux.networking | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
ping Moe Trin buck <buck@private.mil> - 2014-03-05 19:26 +0000
Re: ping Moe Trin Thad Floryan <thad@thadlabs.com> - 2014-03-05 13:44 -0800
Re: ping Moe Trin Jorgen Grahn <grahn+nntp@snipabacken.se> - 2014-03-05 22:15 +0000
Re: ping Moe Trin Moe Trin <ibuprofin@painkiller.example.tld.invalid> - 2014-03-06 01:50 +0000
Re: ping Moe Trin buck <buck@private.mil> - 2014-03-06 07:19 +0000
Re: ping Moe Trin David Brown <david.brown@hesbynett.no> - 2014-03-06 09:38 +0100
Re: ping Moe Trin Richard Kettlewell <rjk@greenend.org.uk> - 2014-03-06 09:54 +0000
Re: ping Moe Trin William Unruh <unruh@invalid.ca> - 2014-03-06 17:43 +0000
Re: ping Moe Trin Rick Jones <rick.jones2@hp.com> - 2014-03-06 19:23 +0000
Re: ping Moe Trin buck <buck@private.mil> - 2014-03-06 20:33 +0000
Re: ping Moe Trin Moe Trin <ibuprofin@painkiller.example.tld.invalid> - 2014-03-07 02:52 +0000
Re: ping Moe Trin "Charlie Gibbs" <cgibbs@kltpzyxm.invalid> - 2014-03-07 14:09 -0800
Re: ping Moe Trin Jorgen Grahn <grahn+nntp@snipabacken.se> - 2014-03-08 20:58 +0000
Re: ping Moe Trin Moe Trin <ibuprofin@painkiller.example.tld.invalid> - 2014-03-09 01:53 +0000
Re: ping Moe Trin Moe Trin <ibuprofin@painkiller.example.tld.invalid> - 2014-03-07 00:22 +0000
csiph-web