Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > comp.lang.php > #3731 > unrolled thread

HELP!!! from PHP 5.16 to 5.3 Unable to load dynamic library

Started byfederico M <federico.migliorini@gmail.com>
First post2011-11-09 12:45 -0800
Last post2011-11-10 13:25 -0500
Articles 10 — 4 participants

Back to article view | Back to comp.lang.php


Contents

  HELP!!! from PHP 5.16 to 5.3 Unable to load dynamic library federico M <federico.migliorini@gmail.com> - 2011-11-09 12:45 -0800
    Re: HELP!!! from PHP 5.16 to 5.3 Unable to load dynamic library Denis McMahon <denismfmcmahon@gmail.com> - 2011-11-09 23:30 +0000
      Re: HELP!!! from PHP 5.16 to 5.3 Unable to load dynamic library federicomo <federico.migliorini@gmail.com> - 2011-11-09 17:26 -0800
        Re: HELP!!! from PHP 5.16 to 5.3 Unable to load dynamic library federicomo <federico.migliorini@gmail.com> - 2011-11-09 17:46 -0800
          Re: HELP!!! from PHP 5.16 to 5.3 Unable to load dynamic library Denis McMahon <denismfmcmahon@gmail.com> - 2011-11-10 03:58 +0000
            Re: HELP!!! from PHP 5.16 to 5.3 Unable to load dynamic library Denis McMahon <denismfmcmahon@gmail.com> - 2011-11-10 04:06 +0000
    Re: HELP!!! from PHP 5.16 to 5.3 Unable to load dynamic library federicomo <federico.migliorini@gmail.com> - 2011-11-10 01:14 -0800
      Re: HELP!!! from PHP 5.16 to 5.3 Unable to load dynamic library Jerry Stuckle <jstucklex@attglobal.net> - 2011-11-10 07:15 -0500
        Re: HELP!!! from PHP 5.16 to 5.3 Unable to load dynamic library federicomo <federico.migliorini@gmail.com> - 2011-11-10 07:10 -0800
          Re: HELP!!! from PHP 5.16 to 5.3 Unable to load dynamic library Jerry Stuckle <jstucklex@attglobal.net> - 2011-11-10 13:25 -0500

#3731 — HELP!!! from PHP 5.16 to 5.3 Unable to load dynamic library

Fromfederico M <federico.migliorini@gmail.com>
Date2011-11-09 12:45 -0800
SubjectHELP!!! from PHP 5.16 to 5.3 Unable to load dynamic library
Message-ID<ff08d24a-484a-490e-9530-2a60e28a9c60@w1g2000vba.googlegroups.com>
I'm not expert!

I Tried to upgrade PHP 5.16 to 5.30 with yum upgrade
it works, but a lot of extensions can't be loaded now


PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib64/
php/modules/gettext.so' - /usr/lib64/php/modules/gettext.so: cannot
open shared object file: No such file or directory in Unknown on line
0
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib64/
php/modules/hyperwave.so' - /usr/lib64/php/modules/hyperwave.so:
cannot open shared object file: No such file or directory in Unknown
on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib64/
php/modules/mime_magic.so' - /usr/lib64/php/modules/mime_magic.so:
cannot open shared object file: No such file or directory in Unknown
on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib64/
php/modules/ming.so' - /usr/lib64/php/modules/ming.so: cannot open
shared object file: No such file or directory in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib64/
php/modules/mssql.so' - /usr/lib64/php/modules/mssql.so: cannot open
shared object file: No such file or directory in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib64/
php/modules/openssl.so' - /usr/lib64/php/modules/openssl.so: cannot
open shared object file: No such file or directory in Unknown on line
0
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib64/
php/modules/pdf.so' - /usr/lib64/php/modules/pdf.so: cannot open
shared object file: No such file or directory in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib64/
php/modules/sockets.so' - /usr/lib64/php/modules/sockets.so: cannot
open shared object file: No such file or directory in Unknown on line
0
....
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib64/
php/modules/xslt.so' - /usr/lib64/php/modules/xslt.so: cannot open
shared object file: No such file or directory in Unknown on line 0
PHP Warning:  Module 'curl' already loaded in Unknown on line 0
PHP Warning:  Module 'gd' already loaded in Unknown on line 0
PHP Warning:  Module 'imap' already loaded in Unknown on line 0

I check where is this extension to insert path... but don't work
a lot of that I can't find really...

where is the standard directory for phpo extension ? (Centos 5.5 Plesk
9.5)
what I can do so solve the problem?

Someone could help me?
thank you!

federico



[toc] | [next] | [standalone]


#3732

FromDenis McMahon <denismfmcmahon@gmail.com>
Date2011-11-09 23:30 +0000
Message-ID<4ebb0d1d$0$28592$a8266bb1@newsreader.readnews.com>
In reply to#3731
On Wed, 09 Nov 2011 12:45:08 -0800, federico M wrote:

> PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib64/
> php/modules/x.so' - /usr/lib64/php/modules/x.so: cannot open
> shared object file: No such file or directory in Unknown on line 0

(repeated for various x)

Sounds like you're missing some libraries, or you have some bad links.

I'd suggest that you try and find out which package installs each of the 
libraries in question (I think these were gettext.so, hyperwave.so, 
mime_magic.so, ming.so, mssql.so, openssl.so, pdf.so, sockets.so, and 
xslt.so, but I might have missed some) and then install those packages.

Rgds

Denis McMahon

[toc] | [prev] | [next] | [standalone]


#3733

Fromfedericomo <federico.migliorini@gmail.com>
Date2011-11-09 17:26 -0800
Message-ID<14669165.77.1320888378232.JavaMail.geo-discussion-forums@yqff21>
In reply to#3732
Yes is not installed but if I install with yum ...nothing change!
like repository was wrong...

But I don't know how to change.

[toc] | [prev] | [next] | [standalone]


#3734

Fromfedericomo <federico.migliorini@gmail.com>
Date2011-11-09 17:46 -0800
Message-ID<24115626.766.1320889582209.JavaMail.geo-discussion-forums@yqhd1>
In reply to#3733
Sorry, thank you for your answer first! 

Try to explain better:
You are right the extensions are not installed, but if I install them I have some warning in php -m ... 

[toc] | [prev] | [next] | [standalone]


#3735

FromDenis McMahon <denismfmcmahon@gmail.com>
Date2011-11-10 03:58 +0000
Message-ID<4ebb4bd9$0$28445$a8266bb1@newsreader.readnews.com>
In reply to#3734
On Wed, 09 Nov 2011 17:46:22 -0800, federicomo wrote:

> Sorry, thank you for your answer first!
> 
> Try to explain better:
> You are right the extensions are not installed, but if I install them I
> have some warning in php -m ...

OK, well it may be that the libraries are installed, but not where php 
expects to find them, or you may have a mixture of 32 bit and 64 bit 
packages that is causing confusion?

Perhaps you have not installed the right php packages, eg on my debian/
ubuntu based server most of the php extensions are in packages named 
"php5-......."

Or it's looking in the wrong place? My .so files are in:

/usr/lib64/php5/20090626 on my 64 bit desktop, and
/usr/lib/php5/20090626+lfs on the 32 bit server

but I can't see anything in my php.ini files that tells php that's where 
the extension libraries are loaded, although I'd assume it was specified 
somewhere.

The dir names can't be coincidence, I must have done software installs on 
both machines on 26th June 2009.

So, perhaps (from a root account), for each relevant x:

find / -name x.so

and if it exists, create a link from where php expects to find it to 
where it actually is, so that php will find it from the link where it's 
currently looking, eg

if x.so is in /usr/lib64/php5/modules/x.so

then make the /usr/lib64/php/modules dir if needed, and create a link:

sudo mkdir /usr/lib64/php
sudo mkdir /usr/lib64/php/modules

ln -s /usr/lib64/php5/modules/x.so /usr/lib64/php/modules/x.so

It's a work around, but it should solve your problem if the issue is that 
the files are present but not where php is expecting them.

Rgds

Denis McMahon

[toc] | [prev] | [next] | [standalone]


#3736

FromDenis McMahon <denismfmcmahon@gmail.com>
Date2011-11-10 04:06 +0000
Message-ID<4ebb4dbd$0$28579$a8266bb1@newsreader.readnews.com>
In reply to#3735
On Thu, 10 Nov 2011 03:58:17 +0000, Denis McMahon wrote:

> The dir names can't be coincidence, I must have done software installs
> on both machines on 26th June 2009.

Ah, I discovered from my phpinfo that the PHP API is 20090626, so that 
would probably be why that date appears in the directory name where my 
module libraries are located.

Rgds

Denis McMahon

[toc] | [prev] | [next] | [standalone]


#3742

Fromfedericomo <federico.migliorini@gmail.com>
Date2011-11-10 01:14 -0800
Message-ID<30929954.396.1320916466843.JavaMail.geo-discussion-forums@yqff21>
In reply to#3731
Thank you Denis,

I have 64bit Centos5.5 Plesk9.5
Directory of extensions is   /usr/lib64/php5/modules/

and it's the defould directory I think...
but in php.ini is written you can specify a different directory and I tried. but not work.

estensions are intalled by YUM so it is all 64bit. I quite sure.
If I look for the ones that give me problem...

ex locate pdf.so

system can't find! but there is in /usr/lib64/php5/modules/ , someone suggest me that there is a problem of installation and repository...
but I don't know what means?

I Installed for example pdf.so  and installation work! but still alert there is :(

Could be a configuration problem of yum? 
how can I check this?

Thank you

[toc] | [prev] | [next] | [standalone]


#3746

FromJerry Stuckle <jstucklex@attglobal.net>
Date2011-11-10 07:15 -0500
Message-ID<j9gf9e$rsh$1@dont-email.me>
In reply to#3742
On 11/10/2011 4:14 AM, federicomo wrote:
> Thank you Denis,
>
> I have 64bit Centos5.5 Plesk9.5
> Directory of extensions is   /usr/lib64/php5/modules/
>
> and it's the defould directory I think...
> but in php.ini is written you can specify a different directory and I tried. but not work.
>
> estensions are intalled by YUM so it is all 64bit. I quite sure.
> If I look for the ones that give me problem...
>
> ex locate pdf.so
>
> system can't find! but there is in /usr/lib64/php5/modules/ , someone suggest me that there is a problem of installation and repository...
> but I don't know what means?
>
> I Installed for example pdf.so  and installation work! but still alert there is :(
>
> Could be a configuration problem of yum?
> how can I check this?
>
> Thank you

Did you stop and restart your Apache server?

If the system can't find a library, either the version of the library is 
not compatible with the current OS or other software, or your load path 
is incorrect.  In neither case is this a PHP problem.

-- 
==================
Remove the "x" from my email address
Jerry Stuckle
JDS Computer Training Corp.
jstucklex@attglobal.net
==================

[toc] | [prev] | [next] | [standalone]


#3747

Fromfedericomo <federico.migliorini@gmail.com>
Date2011-11-10 07:10 -0800
Message-ID<25344924.964.1320937811390.JavaMail.geo-discussion-forums@yqoo7>
In reply to#3746
Yes is a problem of path...for some of that. 
for half of that...remain same problem...

I need a systemist here :)
But you have help me to solve.

Thank you!

[toc] | [prev] | [next] | [standalone]


#3751

FromJerry Stuckle <jstucklex@attglobal.net>
Date2011-11-10 13:25 -0500
Message-ID<j9h4ue$buf$1@dont-email.me>
In reply to#3747
On 11/10/2011 10:10 AM, federicomo wrote:
> Yes is a problem of path...for some of that.
> for half of that...remain same problem...
>
> I need a systemist here :)
> But you have help me to solve.
>
> Thank you!

You need to be checking a newsgroup for your Linux distribution.

-- 
==================
Remove the "x" from my email address
Jerry Stuckle
JDS Computer Training Corp.
jstucklex@attglobal.net
==================

[toc] | [prev] | [standalone]


Back to top | Article view | comp.lang.php


csiph-web