Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > comp.lang.php > #9093 > unrolled thread
| Started by | Jim Higgins <ILikeMy@Privacy.bogus> |
|---|---|
| First post | 2013-04-19 16:16 +0000 |
| Last post | 2013-04-22 14:10 +0200 |
| Articles | 9 on this page of 49 — 11 participants |
Back to article view | Back to comp.lang.php
Rejecting Certain Non-ASCII Characters Jim Higgins <ILikeMy@Privacy.bogus> - 2013-04-19 16:16 +0000
Re: Rejecting Certain Non-ASCII Characters Lew Pitcher <lpitcher@teksavvy.com> - 2013-04-19 12:29 -0400
Re: Rejecting Certain Non-ASCII Characters Daniel Pitts <newsgroup.nospam@virtualinfinity.net> - 2013-04-19 09:30 -0700
Re: Rejecting Certain Non-ASCII Characters Jim Higgins <ILikeMy@Privacy.bogus> - 2013-04-19 21:38 +0000
Re: Rejecting Certain Non-ASCII Characters Jim Higgins <ILikeMy@Privacy.bogus> - 2013-04-19 22:11 +0000
Re: Rejecting Certain Non-ASCII Characters Jerry Stuckle <jstucklex@attglobal.net> - 2013-04-19 12:48 -0400
Re: Rejecting Certain Non-ASCII Characters Jim Higgins <ILikeMy@Privacy.bogus> - 2013-04-19 21:46 +0000
Re: Rejecting Certain Non-ASCII Characters Jerry Stuckle <jstucklex@attglobal.net> - 2013-04-19 18:00 -0400
Re: Rejecting Certain Non-ASCII Characters Thomas 'PointedEars' Lahn <PointedEars@web.de> - 2013-04-20 01:23 +0200
Re: Rejecting Certain Non-ASCII Characters Christoph Becker <cmbecker69@gmx.de> - 2013-04-19 19:38 +0200
Re: Rejecting Certain Non-ASCII Characters Thomas 'PointedEars' Lahn <PointedEars@web.de> - 2013-04-19 22:33 +0200
Re: Rejecting Certain Non-ASCII Characters Christoph Becker <cmbecker69@gmx.de> - 2013-04-19 23:08 +0200
Re: Rejecting Certain Non-ASCII Characters Thomas 'PointedEars' Lahn <PointedEars@web.de> - 2013-04-20 01:12 +0200
Re: Rejecting Certain Non-ASCII Characters Christoph Becker <cmbecker69@gmx.de> - 2013-04-22 13:25 +0200
Re: Rejecting Certain Non-ASCII Characters Thomas 'PointedEars' Lahn <PointedEars@web.de> - 2013-04-22 13:29 +0200
Re: Rejecting Certain Non-ASCII Characters Thomas 'PointedEars' Lahn <PointedEars@web.de> - 2013-04-20 14:08 +0200
Re: Rejecting Certain Non-ASCII Characters Thomas 'PointedEars' Lahn <PointedEars@web.de> - 2013-04-20 17:52 +0200
Re: Rejecting Certain Non-ASCII Characters Jim Higgins <ILikeMy@Privacy.bogus> - 2013-04-19 22:06 +0000
Re: Rejecting Certain Non-ASCII Characters Christoph Becker <cmbecker69@gmx.de> - 2013-04-20 00:26 +0200
Re: Rejecting Certain Non-ASCII Characters Jerry Stuckle <jstucklex@attglobal.net> - 2013-04-19 19:53 -0400
Re: Rejecting Certain Non-ASCII Characters Christoph Becker <cmbecker69@gmx.de> - 2013-04-20 02:36 +0200
Re: Rejecting Certain Non-ASCII Characters Jerry Stuckle <jstucklex@attglobal.net> - 2013-04-19 20:58 -0400
Re: Rejecting Certain Non-ASCII Characters Christoph Becker <cmbecker69@gmx.de> - 2013-04-20 03:34 +0200
Re: Rejecting Certain Non-ASCII Characters Arno Welzel <usenet@arnowelzel.de> - 2013-04-19 22:19 +0200
Re: Rejecting Certain Non-ASCII Characters "M. Strobel" <sorry_no_mail_here@nowhere.dee> - 2013-04-20 10:04 +0200
Re: Rejecting Certain Non-ASCII Characters Thomas 'PointedEars' Lahn <PointedEars@web.de> - 2013-04-20 14:15 +0200
Re: Rejecting Certain Non-ASCII Characters "M. Strobel" <sorry_no_mail_here@nowhere.dee> - 2013-04-20 14:26 +0200
Re: Rejecting Certain Non-ASCII Characters Thomas 'PointedEars' Lahn <PointedEars@web.de> - 2013-04-20 14:34 +0200
Re: Rejecting Certain Non-ASCII Characters Arno Welzel <usenet@arnowelzel.de> - 2013-04-20 14:41 +0200
Re: Rejecting Certain Non-ASCII Characters Jerry Stuckle <jstucklex@attglobal.net> - 2013-04-20 08:43 -0400
Re: Rejecting Certain Non-ASCII Characters Arno Welzel <usenet@arnowelzel.de> - 2013-04-20 14:55 +0200
Re: Rejecting Certain Non-ASCII Characters Jerry Stuckle <jstucklex@attglobal.net> - 2013-04-20 09:04 -0400
Re: Rejecting Certain Non-ASCII Characters Arno Welzel <usenet@arnowelzel.de> - 2013-04-20 21:29 +0200
Re: Rejecting Certain Non-ASCII Characters Jerry Stuckle <jstucklex@attglobal.net> - 2013-04-20 20:03 -0400
Re: Rejecting Certain Non-ASCII Characters Arno Welzel <usenet@arnowelzel.de> - 2013-04-21 06:51 +0200
Re: Rejecting Certain Non-ASCII Characters Arno Welzel <usenet@arnowelzel.de> - 2013-04-21 06:57 +0200
Re: Rejecting Certain Non-ASCII Characters Jerry Stuckle <jstucklex@attglobal.net> - 2013-04-21 08:45 -0400
Re: Rejecting Certain Non-ASCII Characters Tim Streater <timstreater@greenbee.net> - 2013-04-21 15:09 +0100
Re: Rejecting Certain Non-ASCII Characters Jerry Stuckle <jstucklex@attglobal.net> - 2013-04-21 10:29 -0400
Re: Rejecting Certain Non-ASCII Characters Jerry Stuckle <jstucklex@attglobal.net> - 2013-04-21 08:44 -0400
Re: Rejecting Certain Non-ASCII Characters The Natural Philosopher <tnp@invalid.invalid> - 2013-04-20 15:07 +0100
Re: Rejecting Certain Non-ASCII Characters Jerry Stuckle <jstucklex@attglobal.net> - 2013-04-20 20:06 -0400
Re: Rejecting Certain Non-ASCII Characters "M. Strobel" <sorry_no_mail_here@nowhere.dee> - 2013-04-20 17:43 +0200
Re: Rejecting Certain Non-ASCII Characters Thomas 'PointedEars' Lahn <PointedEars@web.de> - 2013-04-20 18:01 +0200
Re: Rejecting Certain Non-ASCII Characters "M. Strobel" <sorry_no_mail_here@nowhere.dee> - 2013-04-20 18:17 +0200
Address munging (was: Rejecting Certain Non-ASCII Characters) Thomas 'PointedEars' Lahn <PointedEars@web.de> - 2013-04-20 18:23 +0200
OT: Address munging (was: Re: Rejecting Certain Non-ASCII Characters) Arno Welzel <usenet@arnowelzel.de> - 2013-04-20 21:25 +0200
Re: Rejecting Certain Non-ASCII Characters Denis McMahon <denismfmcmahon@gmail.com> - 2013-04-20 22:06 +0000
Re: Rejecting Certain Non-ASCII Characters Thomas 'PointedEars' Lahn <PointedEars@web.de> - 2013-04-22 14:10 +0200
Page 3 of 3 — ← Prev page 1 2 [3]
| From | The Natural Philosopher <tnp@invalid.invalid> |
|---|---|
| Date | 2013-04-20 15:07 +0100 |
| Message-ID | <kku7fi$i1k$2@news.albasani.net> |
| In reply to | #9151 |
On 20/04/13 13:55, Arno Welzel wrote: > Jerry Stuckle, 2013-04-20 14:43: > >> On 4/20/2013 8:41 AM, Arno Welzel wrote: >>> M. Strobel, 2013-04-20 14:26: >>> >>> [...] >>>> My code can be easily adapted. And then: >>>> >>>> Wall Street Journal online >>>> >>>> http://online.wsj.com/article/SB10001424052748704805204575594423931135084.html# >>>> >>>> or Reuters >>>> >>>> http://www.reuters.com/article/2011/03/17/us-eu-internet-privacy-idUSTRE72G48Z20110317 >>> If you don't want to use a valid address, then use >>> >>> <invalid@invalid.invalid> >>> >>> Also see <http://www.individual.de/faq.php#5.3> >>> >>> Did you get it now? >>> >>> >> What does this have to do with PHP, troll? > You forgot to ask this M. Strobel and Thomas Lahn as well... > give him some raw fish and he will go back under his bridge. -- Ineptocracy (in-ep-toc’-ra-cy) – a system of government where the least capable to lead are elected by the least capable of producing, and where the members of society least likely to sustain themselves or succeed, are rewarded with goods and services paid for by the confiscated wealth of a diminishing number of producers.
[toc] | [prev] | [next] | [standalone]
| From | Jerry Stuckle <jstucklex@attglobal.net> |
|---|---|
| Date | 2013-04-20 20:06 -0400 |
| Message-ID | <kkvace$5hr$1@dont-email.me> |
| In reply to | #9153 |
On 4/20/2013 10:07 AM, The Natural Philosopher wrote: > On 20/04/13 13:55, Arno Welzel wrote: >> Jerry Stuckle, 2013-04-20 14:43: >> >>> On 4/20/2013 8:41 AM, Arno Welzel wrote: >>>> M. Strobel, 2013-04-20 14:26: >>>> >>>> [...] >>>>> My code can be easily adapted. And then: >>>>> >>>>> Wall Street Journal online >>>>> >>>>> http://online.wsj.com/article/SB10001424052748704805204575594423931135084.html# >>>>> >>>>> >>>>> or Reuters >>>>> >>>>> http://www.reuters.com/article/2011/03/17/us-eu-internet-privacy-idUSTRE72G48Z20110317 >>>>> >>>> If you don't want to use a valid address, then use >>>> >>>> <invalid@invalid.invalid> >>>> >>>> Also see <http://www.individual.de/faq.php#5.3> >>>> >>>> Did you get it now? >>>> >>>> >>> What does this have to do with PHP, troll? >> You forgot to ask this M. Strobel and Thomas Lahn as well... >> > give him some raw fish and he will go back under his bridge. > > > Ah, yes, the troll who uses a 'nym because he's scared to death that someone will find out he's really an out-of-work ditch digger and not the programmer or EE he claims to be strikes again! Keep it up, TNP. The more you do, the more people who are laughing at you. After all, nobody takes you seriously. -- ================== Remove the "x" from my email address Jerry Stuckle JDS Computer Training Corp. jstucklex@attglobal.net ==================
[toc] | [prev] | [next] | [standalone]
| From | "M. Strobel" <sorry_no_mail_here@nowhere.dee> |
|---|---|
| Date | 2013-04-20 17:43 +0200 |
| Message-ID | <atfrchFqpq0U1@mid.uni-berlin.de> |
| In reply to | #9147 |
Am 20.04.2013 14:41, schrieb Arno Welzel: > M. Strobel, 2013-04-20 14:26: > > [...] >> My code can be easily adapted. And then: >> >> Wall Street Journal online >> >> http://online.wsj.com/article/SB10001424052748704805204575594423931135084.html# >> >> or Reuters >> >> http://www.reuters.com/article/2011/03/17/us-eu-internet-privacy-idUSTRE72G48Z20110317 > > If you don't want to use a valid address, then use > > <invalid@invalid.invalid> > > Also see <http://www.individual.de/faq.php#5.3> > > Did you get it now? > > Get what? This domain exists: str@suse122-intel:~/Desktop> dig nowhere.dee @208.67.222.222 ; <<>> DiG 9.9.2-P2 <<>> nowhere.dee @208.67.222.222 ;; global options: +cmd ;; Got answer: ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 17975 ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1 ;; OPT PSEUDOSECTION: ; EDNS: version: 0, flags:; udp: 16384 ;; QUESTION SECTION: ;nowhere.dee. IN A ;; ANSWER SECTION: nowhere.dee. 0 IN A 67.215.65.132 ;; Query time: 68 msec ;; SERVER: 208.67.222.222#53(208.67.222.222) ;; WHEN: Sat Apr 20 17:42:03 2013 ;; MSG SIZE rcvd: 56 /Str.
[toc] | [prev] | [next] | [standalone]
| From | Thomas 'PointedEars' Lahn <PointedEars@web.de> |
|---|---|
| Date | 2013-04-20 18:01 +0200 |
| Message-ID | <5681296.HGuM2lx8Zy@PointedEars.de> |
| In reply to | #9155 |
M. Strobel wrote: > Am 20.04.2013 14:41, schrieb Arno Welzel: >> If you don't want to use a valid address, then use >> >> <invalid@invalid.invalid> >> >> Also see <http://www.individual.de/faq.php#5.3> >> >> Did you get it now? > > Get what? This domain exists: > > str@suse122-intel:~/Desktop> dig nowhere.dee @208.67.222.222 > > ; <<>> DiG 9.9.2-P2 <<>> nowhere.dee @208.67.222.222 > ;; global options: +cmd > ;; Got answer: > ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 17975 > ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1 > > ;; OPT PSEUDOSECTION: > ; EDNS: version: 0, flags:; udp: 16384 > ;; QUESTION SECTION: > ;nowhere.dee. IN A > > ;; ANSWER SECTION: > nowhere.dee. 0 IN A 67.215.65.132 > > ;; Query time: 68 msec > ;; SERVER: 208.67.222.222#53(208.67.222.222) > ;; WHEN: Sat Apr 20 17:42:03 2013 > ;; MSG SIZE rcvd: 56 It figures that you would post the non-authoritative answer from your misconfigured nameserver to support your anti-social behavior. That does not make your From header field value technically valid or socially acceptable, though, because an *address* there has to have at least a FQDN, which nowhere.dee is no where near to. (There is no registry for the dee TLD to begin with. Not *yet*, that is.) Perhaps someone should inform your service provider to *make* you heed the rules. PointedEars -- Prototype.js was written by people who don't know javascript for people who don't know javascript. People who don't know javascript are not the best source of advice on designing systems that use javascript. -- Richard Cornford, cljs, <f806at$ail$1$8300dec7@news.demon.co.uk>
[toc] | [prev] | [next] | [standalone]
| From | "M. Strobel" <sorry_no_mail_here@nowhere.dee> |
|---|---|
| Date | 2013-04-20 18:17 +0200 |
| Message-ID | <atftcrFr6r7U1@mid.uni-berlin.de> |
| In reply to | #9157 |
Am 20.04.2013 18:01, schrieb Thomas 'PointedEars' Lahn: > M. Strobel wrote: > >> Am 20.04.2013 14:41, schrieb Arno Welzel: >>> If you don't want to use a valid address, then use >>> >>> <invalid@invalid.invalid> >>> >>> Also see <http://www.individual.de/faq.php#5.3> >>> >>> Did you get it now? >> >> Get what? This domain exists: >> >> str@suse122-intel:~/Desktop> dig nowhere.dee @208.67.222.222 >> >> ; <<>> DiG 9.9.2-P2 <<>> nowhere.dee @208.67.222.222 >> ;; global options: +cmd >> ;; Got answer: >> ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 17975 >> ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1 >> >> ;; OPT PSEUDOSECTION: >> ; EDNS: version: 0, flags:; udp: 16384 >> ;; QUESTION SECTION: >> ;nowhere.dee. IN A >> >> ;; ANSWER SECTION: >> nowhere.dee. 0 IN A 67.215.65.132 >> >> ;; Query time: 68 msec >> ;; SERVER: 208.67.222.222#53(208.67.222.222) >> ;; WHEN: Sat Apr 20 17:42:03 2013 >> ;; MSG SIZE rcvd: 56 > > It figures that you would post the non-authoritative answer from your > misconfigured nameserver to support your anti-social behavior. That does > not make your From header field value technically valid or socially > acceptable, though, because an *address* there has to have at least a FQDN, > which nowhere.dee is no where near to. (There is no registry for the dee > TLD to begin with. Not *yet*, that is.) > > Perhaps someone should inform your service provider to *make* you heed the > rules. Haha, gotcha, you did not understand what happens. This was one of the spamming name servers, they give an address for anything... Never heard of it? Time to learn. /Str.
[toc] | [prev] | [next] | [standalone]
| From | Thomas 'PointedEars' Lahn <PointedEars@web.de> |
|---|---|
| Date | 2013-04-20 18:23 +0200 |
| Subject | Address munging (was: Rejecting Certain Non-ASCII Characters) |
| Message-ID | <7018846.Vpm0sXdiuA@PointedEars.de> |
| In reply to | #9158 |
M. Strobel wrote: > Am 20.04.2013 18:01, schrieb Thomas 'PointedEars' Lahn: >> M. Strobel wrote: >>> Am 20.04.2013 14:41, schrieb Arno Welzel: >>>> If you don't want to use a valid address, then use >>>> >>>> <invalid@invalid.invalid> >>>> >>>> Also see <http://www.individual.de/faq.php#5.3> >>>> >>>> Did you get it now? >>> >>> Get what? This domain exists: >>> >>> str@suse122-intel:~/Desktop> dig nowhere.dee @208.67.222.222 >>> >>> ; <<>> DiG 9.9.2-P2 <<>> nowhere.dee @208.67.222.222 >>> ;; global options: +cmd >>> ;; Got answer: >>> ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 17975 >>> ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1 >>> >>> ;; OPT PSEUDOSECTION: >>> ; EDNS: version: 0, flags:; udp: 16384 >>> ;; QUESTION SECTION: >>> ;nowhere.dee. IN A >>> >>> ;; ANSWER SECTION: >>> nowhere.dee. 0 IN A 67.215.65.132 >>> >>> ;; Query time: 68 msec >>> ;; SERVER: 208.67.222.222#53(208.67.222.222) >>> ;; WHEN: Sat Apr 20 17:42:03 2013 >>> ;; MSG SIZE rcvd: 56 >> >> It figures that you would post the non-authoritative answer from your >> misconfigured nameserver to support your anti-social behavior. That does >> not make your From header field value technically valid or socially >> acceptable, though, because an *address* there has to have at least a >> FQDN, which nowhere.dee is no where near to. (There is no registry for >> the dee TLD to begin with. Not *yet*, that is.) >> >> Perhaps someone should inform your service provider to *make* you heed >> the rules. > > Haha, gotcha, you did not understand what happens. > > This was one of the spamming name servers, they give an address for > anything... Never heard of it? No, I am not in need of their services. > Time to learn. Why should I learn about how to commit network abuse best? I for one obey the forms. Instead, it is about time for *you* to learn what an address header is before someone makes you to. X-Post & F'up2 news.admin.net-abuse.usenet PointedEars -- Danny Goodman's books are out of date and teach practices that are positively harmful for cross-browser scripting. -- Richard Cornford, cljs, <cife6q$253$1$8300dec7@news.demon.co.uk> (2004)
[toc] | [prev] | [next] | [standalone]
| From | Arno Welzel <usenet@arnowelzel.de> |
|---|---|
| Date | 2013-04-20 21:25 +0200 |
| Subject | OT: Address munging (was: Re: Rejecting Certain Non-ASCII Characters) |
| Message-ID | <5172EBA0.2040207@arnowelzel.de> |
| In reply to | #9155 |
M. Strobel, 2013-04-20 17:43:
> Am 20.04.2013 14:41, schrieb Arno Welzel:
>> M. Strobel, 2013-04-20 14:26:
>>
>> [...]
>>> My code can be easily adapted. And then:
>>>
>>> Wall Street Journal online
>>>
>>> http://online.wsj.com/article/SB10001424052748704805204575594423931135084.html#
>>>
>>> or Reuters
>>>
>>> http://www.reuters.com/article/2011/03/17/us-eu-internet-privacy-idUSTRE72G48Z20110317
>>
>> If you don't want to use a valid address, then use
>>
>> <invalid@invalid.invalid>
>>
>> Also see <http://www.individual.de/faq.php#5.3>
>>
>> Did you get it now?
>>
>>
> Get what? This domain exists:
No it does not:
<sorry_no_mail_here@nowhere.dee>: Host or domain name not found. Name
service
error for name=nowhere.dee type=AAAA: Host not found
But even if it would - i doubt, that <sorry_no_mail_here@nowhere.dee> is
a valid address or that you own the domain nowhere.dee..
In <http://www.individual.de/faq.php#5.3> is very clear about this topic
- either use a *valid* address or <invalid@invalid.invalid>.
--
Arno Welzel
http://arnowelzel.de
http://de-rec-fahrrad.de
[toc] | [prev] | [next] | [standalone]
| From | Denis McMahon <denismfmcmahon@gmail.com> |
|---|---|
| Date | 2013-04-20 22:06 +0000 |
| Message-ID | <kkv3ha$e21$1@dont-email.me> |
| In reply to | #9155 |
On Sat, 20 Apr 2013 17:43:13 +0200, M. Strobel wrote:
> Get what? This domain (nowhere.dee) exists ...
<?php
$hosts[] = "localhost";
$hosts[] = "nowhere.dee";
$hosts[] = "invalid.invalid";
$hosts[] = "example.com";
foreach ( $hosts as $host ) {
$ip = gethostbyname( $host );
if ( $ip == $host )
echo "Error - {$host} - host not found\n";
else
echo "{$host} has ip address {$ip}\n";
}
gives output:
localhost has ip address 127.0.0.1
Error - nowhere.dee - host not found
Error - invalid.invalid - host not found
example.com has ip address 192.0.43.10
What you have defined locally is irrelevant. Internet domains do not
exist unless their tld is registered with the internet GTLD root servers,
and there is a dns query path to the relevant domain nameserver from the
internet GTLD root servers.
If you must obscure your email address, I suggest you use
email@example.com instead. Using <something>@invalid.invalid is just as
bad as using any other made up domain name. (see <http://www.iana.org/
domains/special> )
postmaster@localhost is of course another possibility, and should be
valid everywhere.
--
Denis McMahon, denismfmcmahon@gmail.com
[toc] | [prev] | [next] | [standalone]
| From | Thomas 'PointedEars' Lahn <PointedEars@web.de> |
|---|---|
| Date | 2013-04-22 14:10 +0200 |
| Message-ID | <1708560.gf3Q74PF4m@PointedEars.de> |
| In reply to | #9162 |
Denis McMahon wrote: > What you have defined locally is irrelevant. ACK. > Internet domains do not exist unless their tld is registered with the > internet GTLD root servers, and there is a dns query path to the relevant > domain nameserver from the internet GTLD root servers. Some exist even without being registered that way, though: > If you must obscure your email address, I suggest you use > email@example.com instead. That would be a violation of RFC 5536 by everyday (mis)use of the “example.com” SLD. That domain, and the “example” TLD, are for *examples*, not address munging. See RFC 2606. > Using <something>@invalid.invalid is just as > bad as using any other made up domain name. (see <http://www.iana.org/ > domains/special> ) Some NetNews providers argue that it is technically correct, as because of ,-<http://tools.ietf.org/html/rfc2606> | | ".invalid" is intended for use in online construction of domain | names that are sure to be invalid and which it is obvious at a | glance are invalid. there cannot be a mailbox there. However, the TLDs defined in RFC 2606 are not for address munging; they are “for Testing, & Documentation Examples”. The example SLDs in defined in RFC 2606 are not for address munging either; they “can be used as examples” only. And the current (2009) NetNews RFC does not allow them: ,-<http://tools.ietf.org/html/rfc5536#section-3.1.2> | | 3.1.2. From | | The From header field is the same as that specified in Section 3.6.2 | of [RFC5322], with the added restrictions detailed above in | Section 2.2. | | from = "From:" SP mailbox-list CRLF That is, added *restrictions*, _not_ added freedoms. Because using “.invalid” (or another of those domains) in a *pseudo*-address (RFC 5322, since at least RFC 2822: “a mailbox *receives* mail”) prevents e-mail communication in a non-obvious way (especially to non-English speakers), whereas e-mail communication *is* important to keep Network news clean of one-to-one communication (to clarify misunderstandings before they evolve into flamewars; to give technical or other advice that nobody in the group should know or care about; to arrange for personal meetings; to offer jobs because of obvious technical expertise; etc.), it is still considered anti-social behavior and is subject to killfile rules. Use it for postings that you want to be read (by knowledgable people), *at your own risk*; consider that not being read (by knowledgable people) on NetNews is equivalent to not participate in NetNews at all. > postmaster@localhost is of course another possibility, and should be > valid everywhere. Nonsense. Because it specifies a different mailbox everywhere, *if at all*, it is _not_ Valid. “localhost” is _not_ a *Fully Qualified* *Domain Name*. It is the *hostname* for 127.0.0.1 by default. Unless you are running an MTA on the computer you are reading NetNews with, there cannot be such a mailbox. And then it will be *your* mailbox you would send e-mail to, not the author of the posting. Use that ”address” to annoy people to no end by spamming themselves (worst case scenario is a bounce days later, or an unexpected log file entry) when they are trying to give you friendly off-group advice (or in any of the aforementioned scenarios). See also: <http://www.interhack.net/pubs/munging-harmful/> The paper may be old, but its arguments are still valid. Address munging in any way is *helping* spammers, and *hurting* the NetNews community, including and firstly oneself. IOW, address munging is one of the most stupid things you can do. X-Post & F'up2 news.admin.net-abuse.usenet PointedEars -- Use any version of Microsoft Frontpage to create your site. (This won't prevent people from viewing your source, but no one will want to steal it.) -- from <http://www.vortex-webdesign.com/help/hidesource.htm> (404-comp.)
[toc] | [prev] | [standalone]
Page 3 of 3 — ← Prev page 1 2 [3]
Back to top | Article view | comp.lang.php
csiph-web