Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > comp.lang.java.programmer > #35364 > unrolled thread

Re: "equals" - a bad name?

Started byStanimir Stamenkov <s7an10@netscape.net>
First post2016-08-16 23:33 +0300
Last post2016-08-17 05:04 -0700
Articles 3 — 2 participants

Back to article view | Back to comp.lang.java.programmer

This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by below is the oldest one visible, not the original post.


Contents

  Re: "equals" - a bad name? Stanimir Stamenkov <s7an10@netscape.net> - 2016-08-16 23:33 +0300
    [OT] Re: "equals" - a bad name? Stanimir Stamenkov <s7an10@netscape.net> - 2016-08-17 07:16 +0300
      Re: [OT] Re: "equals" - a bad name? Eric Douglas <e.d.programmer@gmail.com> - 2016-08-17 05:04 -0700

#35364 — Re: "equals" - a bad name?

FromStanimir Stamenkov <s7an10@netscape.net>
Date2016-08-16 23:33 +0300
SubjectRe: "equals" - a bad name?
Message-ID<novtan$gbd$1@dont-email.me>
13 Aug 2016 23:25:20 GMT, Stefan Ram:

> X-Copyright: (C) Copyright 2016 Stefan Ram. All rights reserved.
> 	Distribution through any means other than regular usenet
> 	channels is forbidden. It is forbidden to publish this
> 	article in the world wide web. It is forbidden to change
> 	URIs of this article into links. It is forbidden to remove
> 	this notice or to transfer the body without this notice.

Heh.

>    »a == b« and »a.equals( b )« have two different meanings
>    in Java. Fairly enough, they are written in different
>    ways in Java.
>
>    But what about pronunciation? I believe that »a == b«
>    sometimes is pronunced »a equals b«. And »a.equals( b )«
>    would be pronounced »a equals b«, too! So now, in talks or
>    on the phone (possibly, when thinking in words), the
>    distinction is lost!
>
>    Therefore, »equals« might better have been another name,
>    like, for example, »equivalent«. So, we would have »a == b«
>    and »a.equivalent( b )«.

I've seen elsewhere »a == b« transcribed as »a is same as b« as in 
»a is the same object as b«, or more general »a is the same value as 
b« which makes sense for reference values in Java.

-- 
Stanimir

[toc] | [next] | [standalone]


#35371 — [OT] Re: "equals" - a bad name?

FromStanimir Stamenkov <s7an10@netscape.net>
Date2016-08-17 07:16 +0300
Subject[OT] Re: "equals" - a bad name?
Message-ID<np0oe0$oro$1@dont-email.me>
In reply to#35364
Tue, 16 Aug 2016 23:33:29 +0300, Stanimir Stamenkov:
> 13 Aug 2016 23:25:20 GMT, Stefan Ram:
>
>> X-Copyright: (C) Copyright 2016 Stefan Ram. All rights reserved.
>>     Distribution through any means other than regular usenet
>>     channels is forbidden. It is forbidden to publish this
>>     article in the world wide web. It is forbidden to change
>>     URIs of this article into links. It is forbidden to remove
>>     this notice or to transfer the body without this notice.
>
> Heh.

I wonder if the OP expect participants in the thread to look at his 
headers, and possibly not quote his post they are replying to, so it 
doesn't ultimately get published on the Web as it happens?

https://groups.google.com/forum/#!topic/comp.lang.java.programmer/TDBFdW3M934

-- 
Stanimir

[toc] | [prev] | [next] | [standalone]


#35374 — Re: [OT] Re: "equals" - a bad name?

FromEric Douglas <e.d.programmer@gmail.com>
Date2016-08-17 05:04 -0700
SubjectRe: [OT] Re: "equals" - a bad name?
Message-ID<55bba945-1606-4c64-adc1-1cee7f458a30@googlegroups.com>
In reply to#35371
On Wednesday, August 17, 2016 at 12:16:11 AM UTC-4, Stanimir Stamenkov > I wonder if the OP expect participants in the thread to look at his 
> headers, and possibly not quote his post they are replying to, so it 
> doesn't ultimately get published on the Web as it happens?
> 
> https://groups.google.com/forum/#!topic/comp.lang.java.programmer/TDBFdW3M934
> 

Stefan's posts never show up unless someone replies to them.
I already have gmail so I use Google Groups because it's easiest.

[toc] | [prev] | [standalone]


Back to top | Article view | comp.lang.java.programmer


csiph-web