Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > comp.lang.java.programmer > #35316 > unrolled thread

Re: "equals" - a bad name?

Started byKnute Johnson <nospam@rabbitbrush.frazmtn.com>
First post2016-08-13 22:29 -0700
Last post2016-08-17 05:06 -0700
Articles 2 — 2 participants

Back to article view | Back to comp.lang.java.programmer

This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by below is the oldest one visible, not the original post.


Contents

  Re: "equals" - a bad name? Knute Johnson <nospam@rabbitbrush.frazmtn.com> - 2016-08-13 22:29 -0700
    Re: "equals" - a bad name? Eric Douglas <e.d.programmer@gmail.com> - 2016-08-17 05:06 -0700

#35316 — Re: "equals" - a bad name?

FromKnute Johnson <nospam@rabbitbrush.frazmtn.com>
Date2016-08-13 22:29 -0700
SubjectRe: "equals" - a bad name?
Message-ID<noovk8$j2a$2@dont-email.me>
On 8/13/2016 16:25, Stefan Ram wrote:
>   »a == b« and »a.equals( b )« have two different meanings
>   in Java. Fairly enough, they are written in different
>   ways in Java.
>
>   But what about pronunciation? I believe that »a == b«
>   sometimes is pronunced »a equals b«. And »a.equals( b )«
>   would be pronounced »a equals b«, too! So now, in talks or
>   on the phone (possibly, when thinking in words), the
>   distinction is lost!
>
>   Therefore, »equals« might better have been another name,
>   like, for example, »equivalent«. So, we would have »a == b«
>   and »a.equivalent( b )«.
>

I always say (usually to my self) dot equals as opposed to equals.

-- 

Knute Johnson

[toc] | [next] | [standalone]


#35375

FromEric Douglas <e.d.programmer@gmail.com>
Date2016-08-17 05:06 -0700
Message-ID<1611ab66-e951-471e-ab06-f7819b8c30c0@googlegroups.com>
In reply to#35316
On Sunday, August 14, 2016 at 1:29:53 AM UTC-4, Knute Johnson wrote:
> I always say (usually to my self) dot equals as opposed to equals.
> 

I don't normally code over the phone but if I'm telling someone else what to write I'd say "a == b" is "a equals b" or even "a equals equals b" while "a.equals(b)" is of course "a dot equals b".

[toc] | [prev] | [standalone]


Back to top | Article view | comp.lang.java.programmer


csiph-web