Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > comp.lang.java.programmer > #35314 > unrolled thread

Re: "equals" - a bad name?

Started byEric Sosman <esosman@comcast-dot-net.invalid>
First post2016-08-13 20:56 -0400
Last post2016-08-13 20:56 -0400
Articles 1 — 1 participant

Back to article view | Back to comp.lang.java.programmer

This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by below is the oldest one visible, not the original post.


Contents

  Re: "equals" - a bad name? Eric Sosman <esosman@comcast-dot-net.invalid> - 2016-08-13 20:56 -0400

#35314 — Re: "equals" - a bad name?

FromEric Sosman <esosman@comcast-dot-net.invalid>
Date2016-08-13 20:56 -0400
SubjectRe: "equals" - a bad name?
Message-ID<noofjo$hb4$1@dont-email.me>
On 8/13/2016 7:25 PM, Stefan Ram wrote:
>   »a == b« and »a.equals( b )« have two different meanings
>   in Java. Fairly enough, they are written in different
>   ways in Java.
>
>   But what about pronunciation? I believe that »a == b«
>   sometimes is pronunced »a equals b«. And »a.equals( b )«
>   would be pronounced »a equals b«, too! So now, in talks or
>   on the phone (possibly, when thinking in words), the
>   distinction is lost!
>
>   Therefore, »equals« might better have been another name,
>   like, for example, »equivalent«. So, we would have »a == b«
>   and »a.equivalent( b )«.

     Good point!  I'll hop into my handy time machine, ZROOP!
back twenty-something years, and make them change it.

     Oh, wait: My time machine uses the Date class, and damn'
near the whole thing is deprecated!  So, unfortunately, I
can't fix things for you -- not just now, anyhow.  As soon as
I will have to been fixed my time machine, I'll be gotten back
to you with a downdate.

-- 
esosman@comcast-dot-net.invalid
"Don't be afraid of work. Make work afraid of you." -- TLM

[toc] | [standalone]


Back to top | Article view | comp.lang.java.programmer


csiph-web