Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > comp.lang.java.programmer > #6629 > unrolled thread
| Started by | Ross <rossclement@gmail.com> |
|---|---|
| First post | 2011-07-28 03:20 -0700 |
| Last post | 2011-08-01 13:54 +0200 |
| Articles | 4 on this page of 24 — 14 participants |
Back to article view | Back to comp.lang.java.programmer
Really "BIG" class name wanted Ross <rossclement@gmail.com> - 2011-07-28 03:20 -0700
Re: Really "BIG" class name wanted Patricia Shanahan <pats@acm.org> - 2011-07-28 03:38 -0700
Re: Really "BIG" class name wanted Roedy Green <see_website@mindprod.com.invalid> - 2011-07-28 04:01 -0700
Re: Really "BIG" class name wanted markspace <-@.> - 2011-07-28 06:35 -0700
Re: Really "BIG" class name wanted Ross <rossclement@gmail.com> - 2011-07-29 05:28 -0700
Re: Really "BIG" class name wanted markspace <-@.> - 2011-07-29 06:36 -0700
Re: Really "BIG" class name wanted Robert Klemme <shortcutter@googlemail.com> - 2011-07-29 15:55 +0200
Re: Really "BIG" class name wanted Tom Anderson <twic@urchin.earth.li> - 2011-07-29 14:56 +0100
Re: Really "BIG" class name wanted Tom Anderson <twic@urchin.earth.li> - 2011-07-29 15:08 +0100
Re: Really "BIG" class name wanted Silvio <silvio@moc.com> - 2011-07-29 17:32 +0200
Re: Really "BIG" class name wanted Silvio <silvio@moc.com> - 2011-08-01 13:47 +0200
Re: Really "BIG" class name wanted lewbloch <lewbloch@gmail.com> - 2011-07-29 09:25 -0700
Re: Really "BIG" class name wanted lewbloch <lewbloch@gmail.com> - 2011-07-29 23:08 -0700
Re: Really "BIG" class name wanted Martin Gregorie <martin@address-in-sig.invalid> - 2011-07-30 11:24 +0000
Re: Really "BIG" class name wanted Patricia Shanahan <pats@acm.org> - 2011-07-30 06:10 -0700
Re: Really "BIG" class name wanted Gene Wirchenko <genew@ocis.net> - 2011-08-01 16:22 -0700
Re: Really "BIG" class name wanted Lew <lewbloch@gmail.com> - 2011-07-31 02:29 -0700
Re: Really "BIG" class name wanted Lew <lewbloch@gmail.com> - 2011-08-01 14:22 -0700
Re: "$" in class names reserved [was: Re: Really "BIG" class name wanted] Wayne <nospam@all.invalid> - 2011-08-02 02:33 -0400
Re: Really "BIG" class name wanted Ross <rossclement@gmail.com> - 2011-07-29 05:37 -0700
Re: Really "BIG" class name wanted Bent C Dalager <bcd@pvv.ntnu.no> - 2011-07-30 22:42 +0000
Re: Really "BIG" class name wanted thoolen <thoolen@tholenbot.thorium> - 2011-07-30 23:38 -0400
Re: Really "BIG" class name wanted markspace <-@.> - 2011-07-31 20:32 -0700
Re: Really "BIG" class name wanted Silvio <silvio@moc.com> - 2011-08-01 13:54 +0200
Page 2 of 2 — ← Prev page 1 [2]
| From | Bent C Dalager <bcd@pvv.ntnu.no> |
|---|---|
| Date | 2011-07-30 22:42 +0000 |
| Message-ID | <slrnj3926u.pct.bcd@microbel.pvv.ntnu.no> |
| In reply to | #6646 |
On 2011-07-29, Ross <rossclement@gmail.com> wrote:
> PS: To address Patricia's concerns (which I can understand), then the
> class name "ToolsAndComponents" is bang on for what it is. Just not
> impressive enough. "CircusRingmeister" might be an alternative, but
> not on topic enough.
TheOneClassToRuleThemAll
ok, so maybe a bit awkward.
BinderInDarkness?
Bent.
--
Bent Dalager - bcd@pvv.org - http://www.pvv.org/~bcd
powered by emacs
[toc] | [prev] | [next] | [standalone]
| From | thoolen <thoolen@tholenbot.thorium> |
|---|---|
| Date | 2011-07-30 23:38 -0400 |
| Message-ID | <j12imp$kb9$1@speranza.aioe.org> |
| In reply to | #6696 |
On 30/07/2011 6:42 PM, Bent C Dalager wrote:
> On 2011-07-29, Ross<rossclement@gmail.com> wrote:
>> PS: To address Patricia's concerns (which I can understand), then the
>> class name "ToolsAndComponents" is bang on for what it is. Just not
>> impressive enough. "CircusRingmeister" might be an alternative, but
>> not on topic enough.
>
> TheOneClassToRuleThemAll
Cute.
> ok, so maybe a bit awkward.
>
> BinderInDarkness?
Why not just go for the truth-in-advertising straightforward approach:
public class Antipattern {
...
}
> Bent.
Hey, aren't you that guy that doused this newsgroup in gasoline and set
fire to it a few years ago when someone criticized emacs?
[toc] | [prev] | [next] | [standalone]
| From | markspace <-@.> |
|---|---|
| Date | 2011-07-31 20:32 -0700 |
| Message-ID | <j156o0$q75$1@dont-email.me> |
| In reply to | #6629 |
On 7/28/2011 3:20 AM, Ross wrote: > I'm now building a centralised class for a whole lot of important > functions in a program I'm writing. Here's an example of a similar thing: <http://download.oracle.com/javase/6/docs/api/javax/annotation/processing/ProcessingEnvironment.html> That's the Processing Environment for the Java compiler annotation processor. Notice it's got some things similar to your idea -- getOptions, getTypeUtils, some other stuff like getFiler (the file system, i.e., persistence) and some stuff specific to the problem domain (ElementUtils, Messager, etc.) Notice too it's not a "god object" -- it's only got a few objects contained with in it. It doesn't know everything, just the top level interfaces. That's much closer to what I think of as an ApplicationContext -- half a dozen to a dozen getters max, and only deals with well scoped top level concepts.
[toc] | [prev] | [next] | [standalone]
| From | Silvio <silvio@moc.com> |
|---|---|
| Date | 2011-08-01 13:54 +0200 |
| Message-ID | <4e3693fe$0$23961$e4fe514c@news2.news.xs4all.nl> |
| In reply to | #6629 |
On 07/28/2011 12:20 PM, Ross wrote: > I'm now building a centralised class for a whole lot of important > functions in a program I'm writing. At present, there are too many > "little" objects that are passed around to parts of the application. > E.g. there's a "PropertyHandler" from/to which properties can be read/ > written. There's a global save/load object which can save and load > various types of data items. There's an update notifier so that > updates in one part of the application are sent to other parts of the > application, either end of which might be plugins. Rather than have > too many little object, I'd like to have one "BIG" object which stores > all the little ones, and has methods such as "getPropertyHandler()", > "getSaveLoadMediator()", "getPatchMediator()" etc. This will also > simplify my interface for Plugins. > > But given the importance of this central class, I want a really "BIG" > name for it. I could call it "BigMediator", or "ImportantObjects", but > want a more impressive name. Just thought that calling it > "TheCentralScrutinizer" might work, as well as being a tip of the hat > to Frank Zappa. But particularly since this object will be important > for any future plugin writers, I want a really good class name for it. > > Any suggestions? I think from most responses in this thread a fitting name can be concluded: public class MyMistake ...
[toc] | [prev] | [standalone]
Page 2 of 2 — ← Prev page 1 [2]
Back to top | Article view | comp.lang.java.programmer
csiph-web