Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > comp.lang.java.programmer > #26376
| From | Andreas Leitgeb <avl@gamma.logic.tuwien.ac.at> |
|---|---|
| Newsgroups | comp.lang.java.programmer |
| Subject | pushing the JLS envelope... (6.4.2. Obscuring) |
| Date | 2013-10-18 23:48 +0000 |
| Organization | A noiseless patient Spider |
| Message-ID | <slrnl63i6p.mol.avl@gamma.logic.tuwien.ac.at> (permalink) |
Ok, I know that this breaks conventions and common sense, but
just for the sake of understanding the JLS...
--- snip foo/Foo.java ---
package foo;
public class Foo {
public static String bad_name = "boo!"; // bad name for a field
public static class bad_name { // even worse, because lower case
public static void foo() { }
}
static {
bad_name.foo(); // doesn't work, because field obscures type - Ok.
foo.Foo.bad_name.foo(); // fqn doesn't work, either, but shouldn't it?
}
}
--- end snip ---
JLS (6.4.2. Obscuring) has to say about this case:
- If a field name obscures a type name, then a
fully qualified name for the type can be used
unless the type name denotes a local class (ยง14.3).
("bad_name" isn't a local class, so the "unless"-part doesn't apply.)
Even if the field was non-static, the compiler still doesn't use
the type but rather complains about unavailability of the field,
even with the fqn.
PS: suggesting "rename the field or (better) the type" as a solution
is really missing the point of this post.
Back to comp.lang.java.programmer | Previous | Next — Next in thread | Find similar | Unroll thread
pushing the JLS envelope... (6.4.2. Obscuring) Andreas Leitgeb <avl@gamma.logic.tuwien.ac.at> - 2013-10-18 23:48 +0000
Re: pushing the JLS envelope... (6.4.2. Obscuring) Daniele Futtorovic <da.futt.news@laposte-dot-net.invalid> - 2013-10-19 02:49 +0200
Re: pushing the JLS envelope... (6.4.2. Obscuring) Lew <lewbloch@gmail.com> - 2013-10-19 14:41 -0700
Re: pushing the JLS envelope... (6.4.2. Obscuring) Andreas Leitgeb <avl@gamma.logic.tuwien.ac.at> - 2013-10-20 21:33 +0000
Re: pushing the JLS envelope... (6.4.2. Obscuring) Daniele Futtorovic <da.futt.news@laposte-dot-net.invalid> - 2013-10-22 12:27 +0200
csiph-web