Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > comp.lang.java.programmer > #37479

Re: underscore as keyword in Java 9

From j4n bur53 <janburse@fastmail.fm>
Newsgroups comp.lang.java.programmer
Subject Re: underscore as keyword in Java 9
Date 2017-09-26 13:37 +0200
Organization albasani.net
Message-ID <oqde5c$3t1$1@news.albasani.net> (permalink)
References <slrnoscj1i.ijn.avl@logic.at> <oq635r$alr$1@news.albasani.net> <0b855e3b-6966-4f3b-bfdb-0863c64d7e39@googlegroups.com> <59c97591$0$2072$e4fe514c@newszilla.xs4all.nl> <oqc6om$19to$2@gioia.aioe.org>

Show all headers | View raw


Ok, thats interesting, shorthand for
lambda expressions. Oki Doki.

There is no end to learning...

Arne Vajhøj schrieb:
> On 9/25/2017 5:30 PM, Silvio wrote:
>> I do like what Scala also does with the _ identifier (it also uses it
>> as throw-out identifier). In Scala
>>
>> _ + 1
>>
>> is shorthand for
>>
>> x_1001 => x_1001 + 1
>>
>> and
>>
>> _.toLowerCase
>>
>> is shorthand for
>>
>> x_1002 => x_1002.toLowerCase
>>
>> and Scala goes even further. It defines
>>
>> _ * _
>>
>> to be a shorthand for
>>
>> (x_1003,x_1004) => x_1003 * x_1004
>>
>> This allows for expressions like
>>
>> x.filter(_.length > 1).map(_.toInt).reduce(_ + _)
>>
>> which is far more concise and readable than
>>
>> x.filter(a => a.length > 1).map(b => b.toInt).reduce((c,d) => c + d)
>
> It is definitely shorter.
>
> I am not as convinced about more readable.
>
> Arne

Back to comp.lang.java.programmer | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread


Thread

underscore as keyword in Java 9 Andreas Leitgeb <avl@logic.at> - 2017-09-23 11:58 +0000
  Re: underscore as keyword in Java 9 j4n bur53 <janburse@fastmail.fm> - 2017-09-23 18:46 +0200
    Re: underscore as keyword in Java 9 Arne Vajhøj <arne@vajhoej.dk> - 2017-09-23 21:01 -0400
      Re: underscore as keyword in Java 9 Andreas Leitgeb <avl@logic.at> - 2017-09-24 11:25 +0000
        Re: underscore as keyword in Java 9 j4n bur53 <janburse@fastmail.fm> - 2017-09-24 17:30 +0200
        Re: underscore as keyword in Java 9 Arne Vajhøj <arne@vajhoej.dk> - 2017-09-24 18:24 -0400
          Re: underscore as keyword in Java 9 Andreas Leitgeb <avl@logic.at> - 2017-09-24 23:27 +0000
            Re: underscore as keyword in Java 9 Arne Vajhøj <arne@vajhoej.dk> - 2017-09-24 21:10 -0400
              Re: underscore as keyword in Java 9 Andreas Leitgeb <avl@logic.at> - 2017-09-25 13:30 +0000
    Re: underscore as keyword in Java 9 Eric Douglas <e.d.programmer@gmail.com> - 2017-09-25 08:07 -0700
      Re: underscore as keyword in Java 9 lewbloch@gmail.com - 2017-09-25 13:21 -0700
      Re: underscore as keyword in Java 9 Silvio <silvio@internet.com> - 2017-09-25 23:30 +0200
        Re: underscore as keyword in Java 9 Arne Vajhøj <arne@vajhoej.dk> - 2017-09-25 20:24 -0400
          Re: underscore as keyword in Java 9 j4n bur53 <janburse@fastmail.fm> - 2017-09-26 13:37 +0200
          Re: underscore as keyword in Java 9 Silvio <silvio@internet.com> - 2017-09-27 19:05 +0200
            Re: underscore as keyword in Java 9 Eric Douglas <e.d.programmer@gmail.com> - 2017-09-27 10:25 -0700
              Re: underscore as keyword in Java 9 Silvio <silvio@internet.com> - 2017-09-27 23:02 +0200
            Re: underscore as keyword in Java 9 Arne Vajhøj <arne@vajhoej.dk> - 2017-09-27 20:02 -0400
              Re: underscore as keyword in Java 9 Eric Douglas <e.d.programmer@gmail.com> - 2017-09-28 05:11 -0700
                Re: underscore as keyword in Java 9 Arne Vajhøj <arne@vajhoej.dk> - 2017-09-28 20:42 -0400
          Re: underscore as keyword in Java 9 Sebastian <nowhere@nirvana.org> - 2017-09-27 20:26 +0200
            Re: underscore as keyword in Java 9 Silvio <silvio@internet.com> - 2017-09-27 23:10 +0200
        Re: underscore as keyword in Java 9 Andreas Leitgeb <avl@logic.at> - 2017-09-26 08:29 +0000
          Re: underscore as keyword in Java 9 Silvio <silvio@internet.com> - 2017-09-27 19:08 +0200
          Re: underscore as keyword in Java 9 Sebastian <nowhere@nirvana.org> - 2017-09-27 21:46 +0200
  Re: underscore as keyword in Java 9 Eric Douglas <e.d.programmer@gmail.com> - 2017-09-27 06:53 -0700
    Re: underscore as keyword in Java 9 Andreas Leitgeb <avl@logic.at> - 2017-09-27 15:59 +0000
      Re: underscore as keyword in Java 9 Arne Vajhøj <arne@vajhoej.dk> - 2017-09-27 19:18 -0400
        Re: underscore as keyword in Java 9 Daniele Futtorovic <da.futt.news@laposte.net> - 2017-09-28 11:41 +0200

csiph-web