Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > comp.lang.c > #154846 > unrolled thread
| Started by | Robbie Hatley <see.my.signature@for.my.contact.info> |
|---|---|
| First post | 2020-09-10 19:47 -0700 |
| Last post | 2020-09-14 09:38 -0600 |
| Articles | 5 — 5 participants |
Back to article view | Back to comp.lang.c
This discussion starts older than the indexed window; earlier articles aren't shown. The article labeled Started by
below is the oldest one visible, not the original post.
Re: puzzling enragement by innocuous variable names Robbie Hatley <see.my.signature@for.my.contact.info> - 2020-09-10 19:47 -0700
Re: puzzling enragement by innocuous variable names Keith Thompson <Keith.S.Thompson+u@gmail.com> - 2020-09-10 20:28 -0700
Re: puzzling enragement by innocuous variable names Peter 'Shaggy' Haywood <phaywood@alphalink.com.au> - 2020-09-13 14:57 +1000
Re: puzzling enragement by innocuous variable names gazelle@shell.xmission.com (Kenny McCormack) - 2020-09-15 17:58 +0000
Re: puzzling enragement by innocuous variable names Joe Pfeiffer <pfeiffer@cs.nmsu.edu> - 2020-09-14 09:38 -0600
| From | Robbie Hatley <see.my.signature@for.my.contact.info> |
|---|---|
| Date | 2020-09-10 19:47 -0700 |
| Subject | Re: puzzling enragement by innocuous variable names |
| Message-ID | <8-SdnWoo5bG3eMfCnZ2dnUU7_8zNnZ2d@giganews.com> |
On 2/10/2020 11:14 AM, Keith Thompson wrote: > You posted to a forum full of C programmers. You posted C code. > Did you not want those C programmers to understand your code? If a person does not "understand" the functions of the left and right arguments of main() in C, then that person does not know the C programming language, and that person does not belong in "a forum full of C programmers". > By using silly names... No, that's Chad Dalten's forte. :::eye roll::: > If you do that [fail to express sufficient orthodoxy?] > deliberately, many of us will be less inclined to help you. Excellent. I'm not really interested in conversing with exceedingly-officious persons anyway. Why would I be? Why would ANYONE be? To phrase it another way, if persons on The Internet act excessively-officious deliberately, many of us will be less inclined to pay attention to anything they say. So if they wish to avoid wasting their own time, they should avoid doing that. > You're absolutely right that the compiler doesn't care > what you call the parameters of main. Human readers do. I don't see why. Now, If I'd used variable names designed to trigger people's hot buttons (say, something to do with sex, religion, or politics, or something insulting), then yes. But "Beren" and "Luthien"? No. Not unless JRR Tolkien as an author is universally hated by computer programmers, and I've never seen any evidence of that. Otherwise, no, I see no reason why anyone in this group would find those two names offensive. Frankly, I find this entire conversation silly. Why adult programmers would react so violently to two short, inoffensive variable names, I find exceedingly puzzling. -- Cheers, Robbie Hatley Midway City, CA, USA perl -E 'say "\154o\156e\167o\154f\100w\145ll\56c\157m";' https://www.facebook.com/robbie.hatley https://people.well.com/user/lonewolf/
[toc] | [next] | [standalone]
| From | Keith Thompson <Keith.S.Thompson+u@gmail.com> |
|---|---|
| Date | 2020-09-10 20:28 -0700 |
| Message-ID | <87pn6tgfga.fsf@nosuchdomain.example.com> |
| In reply to | #154846 |
Robbie Hatley <see.my.signature@for.my.contact.info> writes:
> On 2/10/2020 11:14 AM, Keith Thompson wrote:
>> You posted to a forum full of C programmers. You posted C code.
>> Did you not want those C programmers to understand your code?
>
> If a person does not "understand" the functions of the left and
> right arguments of main() in C, then that person does not know
> the C programming language, and that person does not belong in
> "a forum full of C programmers".
I had forgotten about this discussion.
To save others the trouble of looking upthread, you had posted
code using:
int main (int Beren, char *Luthien[])
for some reason. I have nothing to add to what I wrote about it
back in February.
[snip]
--
Keith Thompson (The_Other_Keith) Keith.S.Thompson+u@gmail.com
Working, but not speaking, for Philips Healthcare
void Void(void) { Void(); } /* The recursive call of the void */
[toc] | [prev] | [next] | [standalone]
| From | Peter 'Shaggy' Haywood <phaywood@alphalink.com.au> |
|---|---|
| Date | 2020-09-13 14:57 +1000 |
| Message-ID | <gel03h-181.ln1@aretha.foo> |
| In reply to | #154846 |
Groovy hepcat Robbie Hatley was jivin' in comp.lang.c on Fri, 11 Sep
2020 12:47 pm. It's a cool scene! Dig it.
> On 2/10/2020 11:14 AM, Keith Thompson wrote:
>
>> You posted to a forum full of C programmers. You posted C code.
>> Did you not want those C programmers to understand your code?
>
> If a person does not "understand" the functions of the left and
> right arguments of main() in C, then that person does not know
> the C programming language, and that person does not belong in
> "a forum full of C programmers".
Since you have posted this long after the thread has passed
(apparently; I don't recall seeing it), and included very little
context about the thread, you stand to confuse people, and for no good
reason.
Which brings me to the problem Keith was having with your code. You
stand to baffle those you're asking for help by using non-idiomatic
names for the parameters of main().
>> By using silly names...
>
> No, that's Chad Dalten's forte. :::eye roll:::
Who?
>> If you do that [fail to express sufficient orthodoxy?]
>> deliberately, many of us will be less inclined to help you.
>
> Excellent. I'm not really interested in conversing with
> exceedingly-officious persons anyway. Why would I be?
> Why would ANYONE be?
What? You're not making sense. You don't want to converse with
hard-working people? Huh? You're being confusing again.
And, by calling him officious, you seem to be trying to insult Keith.
He is of assistance to many people in here. He is very knowledgeable
about C, and volunteers his free time in here to help people learn the
C language. You have come here, I assume, to ask about C; and have
received a reply from someone who knows what he's talking about and is
willing to help. And what does he get for this helpfulness? A lame
attempt at insulting. People who can help you may be less inclined to
do so next time you have a question.
> To phrase it another way, if persons on The Internet act
> excessively-officious deliberately, many of us will be less
> inclined to pay attention to anything they say. So if they
> wish to avoid wasting their own time, they should avoid
> doing that.
If persons on The Internet act like whiny-babies, deliberately or
otherwise, many of us will be less inclined to pay attention to
anything they say. So if they wish to avoid wasting their own time,
they should avoid doing that.
>> You're absolutely right that the compiler doesn't care
>> what you call the parameters of main. Human readers do.
>
> I don't see why.
Because it can be confusing. If you don't have a good reason to do it,
then don't. Okay, true; it's not really all that confusing, if you know
C well. But still, why make it harder (even if only a little) for
people to help you?
> Now, If I'd used variable names designed
> to trigger people's hot buttons (say, something to do with
> sex, religion, or politics, or something insulting), then yes.
> But "Beren" and "Luthien"? No. Not unless JRR Tolkien as an
> author is universally hated by computer programmers, and I've
> never seen any evidence of that. Otherwise, no, I see no
> reason why anyone in this group would find those two names
> offensive.
It's not a matter of offense. It's a matter of you doing something
weird without a good reason.
> Frankly, I find this entire conversation silly.
On that we are agreed. So why are you reviving it months after it
ended?
> Why adult
> programmers would react so violently to two short,
> inoffensive variable names, I find exceedingly puzzling.
Please calm down. Nobody's reacting violently. Keith was merely
pointing out that it would be better for you if you stuck to the
established idiom of calling main()'s parameters argc and argv
respectively.
When you're asking for help, help people to help you by making your
code easier to read.
--
----- Dig the NEW and IMPROVED news sig!! -----
-------------- Shaggy was here! ---------------
Ain't I'm a dawg!!
[toc] | [prev] | [next] | [standalone]
| From | gazelle@shell.xmission.com (Kenny McCormack) |
|---|---|
| Date | 2020-09-15 17:58 +0000 |
| Message-ID | <rjqvcp$8903$1@news.xmission.com> |
| In reply to | #154954 |
In article <gel03h-181.ln1@aretha.foo>, Peter 'Shaggy' Haywood <phaywood@alphalink.com.au> wrote a bunch of hosanas to Leader Kiki, ending with: ... > When you're asking for help, help people to help you by making your >code easier to read. Who says he was asking for help? People have lots of reasons for posting to online forums. Being a clueless newbie is only one of them. -- The only thing Trump's made great again is Saturday Night Live.
[toc] | [prev] | [next] | [standalone]
| From | Joe Pfeiffer <pfeiffer@cs.nmsu.edu> |
|---|---|
| Date | 2020-09-14 09:38 -0600 |
| Message-ID | <1bpn6oxtau.fsf@pfeifferfamily.net> |
| In reply to | #154846 |
Robbie Hatley <see.my.signature@for.my.contact.info> writes: > On 2/10/2020 11:14 AM, Keith Thompson wrote: > >> You posted to a forum full of C programmers. You posted C code. >> Did you not want those C programmers to understand your code? > > If a person does not "understand" the functions of the left and > right arguments of main() in C, then that person does not know > the C programming language, and that person does not belong in > "a forum full of C programmers". > >> By using silly names... > > No, that's Chad Dalten's forte. :::eye roll::: > >> If you do that [fail to express sufficient orthodoxy?] >> deliberately, many of us will be less inclined to help you. > > Excellent. I'm not really interested in conversing with > exceedingly-officious persons anyway. Why would I be? > Why would ANYONE be? You're missing the point. You're asking people for help, and then you're requiring them to jump an extra hurdle for no good reason before they can (yes, it's a low hurdle. It's still extra). The natural human reaction is to say, "that's stupid" and go on to someone who really wants help rather than someone who wants to show how clever they are. Most of us went through a phase when we were teenagers of thinking cute variable names were, well, cute. Most of exited that phase the first time we had to read someone else's code with variable names like mopar426 chevy409 ford302
[toc] | [prev] | [standalone]
Back to top | Article view | comp.lang.c
csiph-web