Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > comp.databases.postgresql > #263
| From | "Laurenz Albe" <invite@spam.to.invalid> |
|---|---|
| Newsgroups | comp.databases.postgresql |
| References | (1 earlier) <1317281868.445091@proxy.dienste.wien.at> <j6m21t$3bt$1@speranza.aioe.org> <1317975042.921423@proxy.dienste.wien.at> <j6nfdi$mfh$1@speranza.aioe.org> <1318258124.527489@proxy.dienste.wien.at> |
| Subject | Re: Constraints for R/O ./data/{base, et al.} |
| Date | 2011-10-25 12:37 +0200 |
| Organization | MagistratWien newsserver |
| Message-Id | <1319539080.265361@proxy.dienste.wien.at> |
I wrote: >> If you've never made any changes to the tables/indexes, why >> would VACUUM touch those files? (i.e., assuming the DB had been >> vacuumed prior to being cast in stone) > > I don't know the server code well enough to answer that question > without some research. [...] > To really get definite answers which files in the data directory > will never change, you should look for somebody who knows > PostgreSQL better than I do. I suggest asking the pgsql-hackers > mailing list. I decided to increase my knowledge by playing around a little, and it turns out that you need write permission even to *read* a table. The file is opened with "O_RDWR | PG_BINARY", so even SELECTing from a table whose file is read-only will give you ERROR: could not open file "base/17046/17047": Permission denied That's no bug, because a SELECT can cause writes (update the hint bits). So in order to have something like PostgreSQL tables on read-only media, you'd definitely have to hack up PostgreSQL. Yours, Laurenz Albe
Back to comp.databases.postgresql | Previous | Next — Previous in thread | Find similar | Unroll thread
Constraints for R/O ./data/{base, et al.} Don Y <nowhere@here.com> - 2011-09-28 08:58 -0700
Re: Constraints for R/O ./data/{base, et al.} Mladen Gogala <gogala.mladen@gmail.com> - 2011-09-28 18:51 +0000
Re: Constraints for R/O ./data/{base, et al.} "Laurenz Albe" <invite@spam.to.invalid> - 2011-09-29 09:37 +0200
Re: Constraints for R/O ./data/{base, et al.} Don Y <nowhere@here.com> - 2011-10-06 22:17 -0700
Re: Constraints for R/O ./data/{base, et al.} "Laurenz Albe" <invite@spam.to.invalid> - 2011-10-07 10:10 +0200
Re: Constraints for R/O ./data/{base, et al.} Don Y <nowhere@here.com> - 2011-10-07 11:12 -0700
Re: Constraints for R/O ./data/{base, et al.} Mladen Gogala <gogala.mladen@gmail.com> - 2011-10-08 05:48 +0000
Re: Constraints for R/O ./data/{base, et al.} "Laurenz Albe" <invite@spam.to.invalid> - 2011-10-10 16:48 +0200
Re: Constraints for R/O ./data/{base, et al.} "Laurenz Albe" <invite@spam.to.invalid> - 2011-10-25 12:37 +0200
csiph-web