Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > comp.lang.python > #43618

Re: classes and sub classes?

From Neil Cerutti <neilc@norwich.edu>
Newsgroups comp.lang.python
Subject Re: classes and sub classes?
Date 2013-04-15 12:22 +0000
Organization Norwich University
Message-ID <at29ntFpjjtU1@mid.individual.net> (permalink)
References <mailman.313.1365486619.3114.python-list@python.org> <5163be52$0$29977$c3e8da3$5496439d@news.astraweb.com> <CACQBTrRVs1G_LP7d0+e=gxB18-zDGKPr7kXy=_A-2RB8YHEhfw@mail.gmail.com> <CANy1k1imR+yynBjWhGx5OU6FE2jC9hcB+yHuMF6r2GEwY3m39g@mail.gmail.com> <mailman.622.1366010485.3114.python-list@python.org>

Show all headers | View raw


On 2013-04-15, Peter Otten <__peter__@web.de> wrote:
> Jason Friedman wrote:
>>> NwInvDb = NetworkInventoryDatabase, yes you are correct, it
>>> creates the database handle and makes it ready for use.
>> 
>> I am interested in opinions.  I for one dislike abbreviations
>> on the theory that programs are read more than they are
>> written.  I would probably use this variable name:
>> 
>> network_inventory_db_connection = ...
>> 
>> And yes, I'm aware that "db" is an abbreviation.  I believe I am following
>> a few Zen principles:
>> 
>> Beautiful is better than ugly.
>> Explicit is better than implicit.
>> Readability counts.
>> Special cases aren't special enough to break the rules, Although
>> practicality beats purity.
>> 
>> What would others use?
>
> inventory_db
>
> The rest should be clear from the context.

How long and descriptive a name is ought to depend on the
wideness of its visibility. n might be acceptable in a short
comprehension, while network_inventory_db_connection might be
apposite for a module-level name.

-- 
Neil Cerutti

Back to comp.lang.python | Previous | NextPrevious in thread | Find similar | Unroll thread


Thread

classes and sub classes? Morten Guldager <morten.guldager@gmail.com> - 2013-04-09 07:50 +0200
  Re: classes and sub classes? Steven D'Aprano <steve+comp.lang.python@pearwood.info> - 2013-04-09 07:08 +0000
    Re: classes and sub classes? Morten Guldager <morten.guldager@gmail.com> - 2013-04-09 09:38 +0200
    Re: classes and sub classes? Jason Friedman <jsf80238@gmail.com> - 2013-04-14 19:38 -0600
    Re: classes and sub classes? MRAB <python@mrabarnett.plus.com> - 2013-04-15 03:07 +0100
    Re: classes and sub classes? Dennis Lee Bieber <wlfraed@ix.netcom.com> - 2013-04-14 22:35 -0400
    Re: classes and sub classes? Peter Otten <__peter__@web.de> - 2013-04-15 09:21 +0200
      Re: classes and sub classes? Neil Cerutti <neilc@norwich.edu> - 2013-04-15 12:22 +0000

csiph-web