Path: csiph.com!1.us.feeder.erje.net!feeder.erje.net!2.eu.feeder.erje.net!feeder2.usenet.farm!feeder1.xsusenet.com!feeders.as203319.net!feeder03.as203319.net!aioe.org!bofh.it!news.nic.it!robomod From: Baole Ni Newsgroups: linux.kernel Subject: [PATCH 0369/1285] Replace numeric parameter like 0444 with macro Date: Tue, 02 Aug 2016 19:40:01 +0200 Message-ID: X-Extloop1: 1 X-Ironport-Av: E=Sophos;i="5.28,460,1464678000"; d="scan'208";a="1006937147" X-Mailer: git-send-email 2.9.2 Sender: robomod@news.nic.it List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Approved: robomod@news.nic.it Lines: 27 Organization: linux.* mail to news gateway X-Original-Cc: linux-media@vger.kernel.org, linux-kernel@vger.kernel.org, chuansheng.liu@intel.com, baolex.ni@intel.com X-Original-Date: Tue, 2 Aug 2016 19:04:50 +0800 X-Original-Message-ID: <20160802110450.6349-1-baolex.ni@intel.com> X-Original-Sender: linux-kernel-owner@vger.kernel.org Xref: csiph.com linux.kernel:1455148 I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro. Signed-off-by: Chuansheng Liu Signed-off-by: Baole Ni --- drivers/media/dvb-frontends/rtl2832_sdr.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/media/dvb-frontends/rtl2832_sdr.c b/drivers/media/dvb-frontends/rtl2832_sdr.c index 47a480a..3f25ba6 100644 --- a/drivers/media/dvb-frontends/rtl2832_sdr.c +++ b/drivers/media/dvb-frontends/rtl2832_sdr.c @@ -38,7 +38,7 @@ #include static bool rtl2832_sdr_emulated_fmt; -module_param_named(emulated_formats, rtl2832_sdr_emulated_fmt, bool, 0644); +module_param_named(emulated_formats, rtl2832_sdr_emulated_fmt, bool, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH); MODULE_PARM_DESC(emulated_formats, "enable emulated formats (disappears in future)"); /* Original macro does not contain enough null pointer checks for our need */ -- 2.9.2