Path: csiph.com!1.us.feeder.erje.net!feeder.erje.net!1.eu.feeder.erje.net!weretis.net!feeder4.news.weretis.net!news.mixmin.net!aioe.org!gothmog.csi.it!bofh.it!news.nic.it!robomod From: Ian Abbott Newsgroups: linux.kernel Subject: Re: [PATCH 05/14] staging: comedi: daqboard2000: rename serial EEPROM register macros Date: Wed, 18 May 2016 12:30:02 +0200 Message-ID: References: X-Auth-ID: abbotti@mev.co.uk X-Sender-ID: abbotti@mev.co.uk User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Icedove/38.6.0 MIME-Version: 1.0 Content-Type: text/plain; charset=windows-1252; format=flowed Content-Transfer-Encoding: 7bit Sender: robomod@news.nic.it List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Approved: robomod@news.nic.it Lines: 56 Organization: linux.* mail to news gateway X-Original-Cc: Greg Kroah-Hartman , "linux-kernel@vger.kernel.org" X-Original-Date: Wed, 18 May 2016 11:25:29 +0100 X-Original-Message-ID: <573C4319.8020007@mev.co.uk> X-Original-References: <1463478773-5916-1-git-send-email-abbotti@mev.co.uk> <1463478773-5916-6-git-send-email-abbotti@mev.co.uk> X-Original-Sender: linux-kernel-owner@vger.kernel.org Xref: csiph.com linux.kernel:1402866 On 17/05/16 18:22, Hartley Sweeten wrote: > On Tuesday, May 17, 2016 2:53 AM, Ian Abbott wrote: >> Rename the macros defining values for the Serial EEPROM Control Register >> to avoid CamelCase. >> >> Signed-off-by: Ian Abbott >> --- >> drivers/staging/comedi/drivers/daqboard2000.c | 26 +++++++++++++------------- >> 1 file changed, 13 insertions(+), 13 deletions(-) >> >> diff --git a/drivers/staging/comedi/drivers/daqboard2000.c b/drivers/staging/comedi/drivers/daqboard2000.c >> index fde0924..b3b68e8 100644 >> --- a/drivers/staging/comedi/drivers/daqboard2000.c >> +++ b/drivers/staging/comedi/drivers/daqboard2000.c >> @@ -116,12 +116,12 @@ >> #define DAQBOARD2000_SUBSYSTEM_IDS4 0x0004 /* Daqboard/2000 - 4 Dacs */ > > Ian, > > This board uses a PLX-9080 chip for the PCI interface. > > If would be better to include and use the register/bit defines > to remove the magic numbers. I was planning to do that, but want to massage plx9080.h a bit first. > > The only PLX register used is PLX_CONTROL_REG (0x6c). > >> /* Initialization bits for the Serial EEPROM Control Register */ >> -#define DAQBOARD2000_SECRProgPinHi 0x8001767e >> -#define DAQBOARD2000_SECRProgPinLo 0x8000767e >> -#define DAQBOARD2000_SECRLocalBusHi 0xc000767e >> -#define DAQBOARD2000_SECRLocalBusLo 0x8000767e >> -#define DAQBOARD2000_SECRReloadHi 0xa000767e >> -#define DAQBOARD2000_SECRReloadLo 0x8000767e >> +#define DAQBOARD2000_SECR_PROG_PIN_HI 0x8001767e >> +#define DAQBOARD2000_SECR_PROG_PIN_LO 0x8000767e >> +#define DAQBOARD2000_SECR_LOCAL_BUS_HI 0xc000767e >> +#define DAQBOARD2000_SECR_LOCAL_BUS_LO 0x8000767e >> +#define DAQBOARD2000_SECR_RELOAD_HI 0xa000767e >> +#define DAQBOARD2000_SECR_RELOAD_LO 0x8000767e > > These "Initialization bits" are just various combinations of the > PLX_CONTROL_REG bit defines (CTL_*) to toggle the various > EEPROM bits. Yes, it would be better to read the control register and only change the bits of interest. I plan to do some more work on this driver. This series is mainly to get the checkpatch warnings (well, most of them) out of the way first. -- -=( Ian Abbott @ MEV Ltd. E-mail: )=- -=( Web: http://www.mev.co.uk/ )=-