Path: csiph.com!news.mixmin.net!news.albasani.net!.POSTED!not-for-mail From: christian_dcsm-ENTF@soemtron.de (Christian @Soemtron) Newsgroups: de.comm.software.mailreader Subject: Re: 8bit-Dateinamen Umwandlung Date: 04 Aug 2017 11:46:00 +0200 Organization: albasani.net Lines: 65 Message-ID: References: Mime-Version: 1.0 Content-Type: text/plain; charset=ISO-8859-1 Content-Transfer-Encoding: 8bit X-Trace: news.albasani.net 5zhNgPPjrhxGdzFZ2q9ytDXFII3VeuTlKWdaEE9fN1amzRYuJa24dqqK8aEdKu0KPXGt494SHYcYhVOPDrojNQ== NNTP-Posting-Date: Fri, 4 Aug 2017 09:54:48 +0000 (UTC) Injection-Info: news.albasani.net; logging-data="QOXd/TNlRlRQdWL7V7t5xQ385ptyG6OBNptIVDhkDa2RIDSfbNVxMDoImzMppaJuobeoEkJwpvMXWkUM5W/Dxm6Q5Ol6SCEtwcA/3onMgMm5UZcZ4FDgixzY4KTyZWrk"; mail-complaints-to="abuse@albasani.net" X-No-Archive: yes X-Newsreader: Crosspoint 4.0 Cancel-Lock: sha1:12Wo8shjfmonLkIXtQ5XAaxhOiM= Xref: csiph.com de.comm.software.mailreader:285 Michael Bäuerle schrieb: > Ich kann deine Frage nicht beantworten, aber ich finde obige > Auswahl irreführend: RFC 2231 gehört zur MIME Definition genau wie > RFC 2047 (und auch RFC 2045, 2046, 2048 und 2049). danke, Wie wären denn passendere Formulierungen für die Optionen? > | [...] > | Content-Disposition: attachment; > | filename*=utf-8''%74%C3%A4%73%74%2E%74%78%74 > So ist es seit 20 Jahren genormt (gemäß den MIME-Normen RFC 2183 > und RFC 2231): Hier das Ergebnis jeweils mit Datei "Ölfaß.txt": ========== "MIME" ======================================================== Content-Transfer-Encoding: 7bit --------_boundary Content-Type: application/octet-stream; name="=?ISO-8859-1?Q?=D6lfa=DF=2Etxt?=" Content-Disposition: attachment; filename="=?ISO-8859-1?Q?=D6lfa=DF=2Etxt?=" ========== "RFC2231" ===================================================== Content-Transfer-Encoding: 7bit --------_boundary Content-Type: application/octet-stream; name*=iso-8859-1''%D6lfa%DF%2Etxt Content-Disposition: attachment; filename*=iso-8859-1''%D6lfa%DF%2Etxt ========== "Raw" ========================================================= Content-Transfer-Encoding: 8bit --------_boundary Content-Type: application/octet-stream; name*=iso-8859-1''%D6lfa%DF%2Etxt Content-Disposition: attachment; filename*=iso-8859-1''%D6lfa%DF%2Etxt =========================================================================== Es bleibt die Frage, mit welcher Variante man mit weniger Problemen auf Empfängerseite rechnen muß: #1 oder #2. Nach 20 Jahren könnte man ja fast annehmen, daß sich der Standard flächendeckend durchgesetzt hat. #3 unterscheidet sich von #2 nur durch "Content-Transfer-Encoding: 8bit" im Haupt-Header. Was könnte das mit den Dateinamen zu tun haben? Davon abgesehen: von 8bit-Codierung meine ich gelesen zu haben, daß das zwar "moderner" und Standard, aber in seltenen Fällen dann doch mal problematisch ist. Da gehe ich lieber auf Nummer sicher, der Empfänger kann ja nichts für evtl. zwischenliegende veraltete Software. cu, Christian PGP Key available.