Path: csiph.com!v102.xanadu-bbs.net!xanadu-bbs.net!news.glorb.com!border3.nntp.dca.giganews.com!border1.nntp.dca.giganews.com!nntp.giganews.com!npeer03.iad.highwinds-media.com!news.highwinds-media.com!feed-me.highwinds-media.com!spln!extra.newsguy.com!newsp.newsguy.com!news6 From: buck Newsgroups: comp.os.linux.networking Subject: Re: "Timeout" DNS IP to name resolution Date: 24 Jun 2012 19:50:37 GMT Organization: Say What? Lines: 54 Message-ID: References: <0g9jb9xf9.ln2@news.roaima.co.uk> NNTP-Posting-Host: pa5ce19246f5470fce4210edfda02c945e2a24aa89e957880.newsdawg.com User-Agent: Xnews/2006.08.24 X-Received-Bytes: 2507 Xref: csiph.com comp.os.linux.networking:1490 Moe Trin wrote in news:slrnjueetk.k4l.ibuprofin@fermi.phx.az.us: > The DNS RFCs were written before RFC2119 (Key words for use in RFCs to > Indicate Requirement Levels) so there isn't a specific sentence that > says PTR records "MUST" (or even "SHOULD") exist. > >>I had a quick look through RFCs 1034 and 1035 yesterday evening but >>couldn't a definite statement. > > RFC 2050 Internet Registry IP Allocation Guidelines section 5 > RFC 2181 Clarifications to the DNS Specification section 10.2 > RFC 2317 Classless IN-ADDR.ARPA delegation entire doc. > > none of which are "STANDARD" track documents. > >>In your situation I suspect that my *opinion* is irrelevant, but FWIW >>I would say that you *should* get some sort of response for any DNS >>enquiry, whether forward or reverse. > > It seems that things fall into three main classes: > > 1. That information is SECRET - I don't want you to know it > 2. It's too HARD to set up > 3. What's a reverse zone > > This has been an on-going problem for many years - mail administrators > often configure their mail servers to reject mail from systems that > don't resolve, or where the forward and reverse names don't match up. > See question 3.22 in the Sendmail-FAQ as one example. [Moe Trin|Olg Guy] Thanks. My reading of 1035 says NO, reverse is not required, but others disagree so what do I know?! All the RFCs I read that talk about Email say that rDNS is NOT required, so I presume that the same goes for http. Pascal & Chris, Thanks. I changed to a different nameserver and get the expected results. I'm confounded because only 4 netblocks (so far) were timing out, but since they no longer do I really don't care to pursue this. -- buck