Path: csiph.com!fu-berlin.de!uni-berlin.de!individual.net!not-for-mail From: Robert Klemme Newsgroups: comp.lang.java.programmer Subject: Re: can someone chk is this code ok and if i can make it better please state how Date: Sat, 7 Jan 2017 14:16:15 +0100 Lines: 23 Message-ID: References: Mime-Version: 1.0 Content-Type: text/plain; charset=utf-8; format=flowed Content-Transfer-Encoding: 7bit X-Trace: individual.net i/6eVch/cCQhzDqdeRr3Tgj7+2XATJAL/XAgohxTlRgZW8Bzo= Cancel-Lock: sha1:u1T9ldkQ7xK+lAhXshpNv3maUTQ= User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Thunderbird/45.5.1 In-Reply-To: Xref: csiph.com comp.lang.java.programmer:36169 On 06.01.2017 22:15, Eric Sosman wrote: > The "The" parts of these method names don't communicate much, and > seem to be little more than clutter. (Why not "getThatWeight" or > "getAPrice"?) It would be more usual to use names like "getModel" > and "getSize" instead. Another remark about naming of methods and fields: the current state of affairs does not adhere to the Java Beans spec and usual convention for getters and setters. So it would be private String model; public String getModel() { return model; } Kind regards robert -- remember.guy do |as, often| as.you_can - without end http://blog.rubybestpractices.com/